North American Turbocoupe Organization



Wot slow acceleration, massive tach bounce
Jimmy Yeo Offline
Junior Member
#1
Car usually runs pretty good, however when I go wide open on it in 3rd gear and up, it has really slow acceleration and the tach jumps maybe 1500-2500 rpm at a time until I let off, i replaced the tfi/pip and it's still doing it but only under a heavy load. I'm going crazy!
Any help?
1987 TC 2.3 5spd project/DD
Reply

Pete D Offline
Administrator
#2
Was anything unusual happening just before this happened - some kind of maintenance/modification? Is the car reading the usual amount of boost at full boost? Do you hear any unusual noise like some kind of air noise or metal rubbing? Is the engine speed jumping around when the tach jumps? Does the tach jump any at idle?
Pete Dunham


Reply

Jimmy Yeo Offline
Junior Member
#3
The engine speed stays the same, it just bounces like crazy and has slow acceleration, and somewhat of a bucking sometimes. I don't like to bag it very often because I'm scared I'll break something the way it acts. I'm running 17lbs of boost. And nothing big changed it just did it one day... In the way home tonight I went wot and after letting off it made a big popping sound, however I am on just a downpipe and mid dumping just before the axle. So I'm unsure but it was louder than usual. Could it be pinging? Stock timing 94 octane
1987 TC 2.3 5spd project/DD
Reply

Pete D Offline
Administrator
#4
Check the cam timing. Maybe the belt jumped a tooth or two? It's a good place to start.
http://turbotbird.com/techinfo/CamTiming...t%20Up.htm
Pete Dunham


Reply

Jimmy Yeo Offline
Junior Member
#5
Cam timing seems to be alright, it'll rev up to red line, and run no problem as long as I don't floor it, even if I get into boost it runs okay but as soon as the pedal hits the floor I go nowhere, the car just gets louder. Today it fell on it's face around 4000 rpm and the tach still bounces between 2500 and 4500 rpm. Could it maybe be my coil failing under load? Or possibly the ecu? I have a spare ecu I swapped in but I have yet to drive it. And I also have a slight putt putt at idle that goes away above 1500 rpm, water comes out the exhaust too. It's super slow too I had trouble keeping up with my friends cavalier which I know I could beat...
1987 TC 2.3 5spd project/DD
Reply

Jimmy Yeo Offline
Junior Member
#6
I found the problem! A small boost leak mixed with plugs gapped at .044 will do it. New plugs and fixed that and it's good!
1987 TC 2.3 5spd project/DD
Reply





Users browsing this thread:
1 Guest(s)



Theme © iAndrew 2018 - Software MyBB