North American Turbocoupe Organization



tranny ?'s
kwiksilver3441 Offline
Member
#1
ok i finally did it. i changed out my slipping clutch disc and plate had my flywheel milled (looks nice) and everything is back together. only prob is now i have a vibration noise at certain rpms feels like the shifter knob is going to shake right off my car. i have an 84 turbocoupe with the mechanical clutch. PLEASE someone help me to find this shake. I can slip it into neutral when the car is in motion and it still makes the noise but not when i am at a stand still. i think it might be my driveshaft vibrating but dont know how this could have happened. the driveshaft had no work done on it except that it was removed from the car to let the trannny down. It had no work because the u-joints looked fine and still swiveled nicely. i grabbed the shaft yesterday and shook it and it sounded stabile with just a little side to side play but not enough to seem to make that loud of a vibration.
Reply

Pete D Offline
Administrator
#2
Make sure the driveshaft bolts in the rear got tightened up. If they weren't tight to begin with they will get real loose quick
Pete Dunham


Reply

kwiksilver3441 Offline
Member
#3
how in the hell do i get my torque wrench into such a tight fit to wrench them bolts to the specified torque? i was told not to use extenstions on torque wrenches because it would throw off the lbs setting?
Reply

Pete D Offline
Administrator
#4
You would have to be Houdini to use a torque wrench on those bolts. Use the universal torque setting: "tightenuff"

------------------
NATO Member. it's not a vice, it's an obsession
Good judgement comes from bad experience, and a lot of that comes from bad judgment.
88 TC X 2, 86 SVO, mods list at
http://www.turbotbird.com/showroom/pd_88tc.htm
Pete Dunham


Reply





Users browsing this thread:
1 Guest(s)



Theme © iAndrew 2018 - Software MyBB