North American Turbocoupe Organization



timing problem
leroy_420b Offline
Junior Member
#1
I just recently changed spark plug wires and spark plugs had to drop the tranny only to find the oil leak was on the turbo feed line since i put it back to gether it keeps pulling boost out if i get on it i checked the timing and it was at 28 btdc but the distributer wasnt loose and last time i set it it was at 12 degrees now everytime i pull the plug and then set it to 12 and then shut it off it goes right back to 28 degrees please help i love this car but it is on my last nerve it is an 88 tc thanks
88 tc gillis k&N 86 tc getting all the goodies from the 88 plus ported e-6 3 inch exhaust ranger roller ported intake manifolds not sure what else should be rolling sometime next year
Reply

Pete D Offline
Administrator
#2
You set the "mechanical timing" with the spout out at, say 10-12*. That is just the mechanical advance with no computer timing added. Whenyou put the spout back in then that allows the computer to add timing and it shouuld add 20* +/- 3*

Quote:since i put it back to gether it keeps pulling boost out if i get on it
Is it pulling boost or pulling timing? If it's losing boost check to be sure none of the IC hoses are cracked, that they are all properly located and clamped. It's real easy to fold the lip of the hose in on itself on the bottom hose.

No offense intended but a little puctuation would make your post a lot eassier to read.
Pete Dunham


Reply

leroy_420b Offline
Junior Member
#3
sorry about that. all of the hoses were tight i think that i just got some bad gas. It seems to have gone away. Thanks
88 tc gillis k&N 86 tc getting all the goodies from the 88 plus ported e-6 3 inch exhaust ranger roller ported intake manifolds not sure what else should be rolling sometime next year
Reply





Users browsing this thread:
1 Guest(s)



Theme © iAndrew 2018 - Software MyBB