North American Turbocoupe Organization



Stumbiling at idle
1988turbotbird Offline
Senior Member
#1
Now I got a new problem. I start the car, about a minute (sometimes sooner) after the idles up and wayyy down, almost stalling, then it picks it self up and keeps doing it. The more the engine warms up, the less it does it, then it eventualy stops and runs great. I already replaced the ECT on the intake with a Motorcraft one, also new Motorcraft wires, Motorcraft cap, Motorcraft rotor, Motorcraft pip and TFI, remanufactured Bosch VAM, new duralast TPS, duralast IAC, EGR valve...help!
88 TC/HX35/CAI/3" exhaust/Wilson MS2/Beanman header/Head Work/Laramee Cam/Gillis boost controller/3G alt/Walboro 255 fuel pump/BOV/CHE rear control arms/1" lowered/poly. bushings/Chuck W mounts/6 puck clutch/Pro 5.0 shifter/AEM wideband/Tuning MS..
Reply

junkedturbo Offline
Senior Member
#2
Take off your IAC and blast it with PB blaster, put it back on a see if keeps it up.

The IAC makes the car idle higher to worm up the engine, most of the time they get dirty and act up.
Reply

etc1006 Offline
Member
#3
I usually do my IAC when the cooler weather hits. That way it'll have the high warmup idle when its winter time.
-Eric
Reply

Nsw Offline
Senior Member
#4
my old car did the exact same thing, only when it was cold out(below zero)
never did figure out why. i did clean out the IAC didd not help
1988 5speed black every option. 3inch single turbo to tail(stinger), manual boost control. k&n cone walbro fuel pump

1986 xr4ti project car..... way to many mods to list.
Reply

Jeff K Offline
Administrator
#5
Sticking VAM door? Vac leak that only opens when cold? Have you run codes?
Jeff Korn

88 Turbo Coupe: Intake and exhaust mods, T3 turbo at 24 psi, forced air IC, water injection, BPV, Ranger cam, subframes, etc., etc.
86 Tbird 5.0 (original owner): intake, exhaust, valvetrain mods, 100 HP N2O, ignition, gears, suspension, etc., etc.
05 Taurus SEL Duratec daily driver
04 Taurus Duratec (wifes car)
02 Pontiac Grand Prix GT
95 Taurus GL Vulcan winter beater
67 Honda 450 Super Sport - completely customized
Reply

MeAndMyT Offline
Senior Member
#6
Sounds like my car when the TPS was bad... Run the codes buddy!
88 TC 5 spd 22x,xxx miles Ran 15.3 in 1/4.. K&N Cone. Gillis boost controller @ 15. Faze Boost Gauge. A/C belt off. 2 1/2 inch exhaust dumped at axles.
Reply

1988turbotbird Offline
Senior Member
#7
I'll check the codes whenI get home, theres no check engine light on, but there still could be codes
88 TC/HX35/CAI/3" exhaust/Wilson MS2/Beanman header/Head Work/Laramee Cam/Gillis boost controller/3G alt/Walboro 255 fuel pump/BOV/CHE rear control arms/1" lowered/poly. bushings/Chuck W mounts/6 puck clutch/Pro 5.0 shifter/AEM wideband/Tuning MS..
Reply

1988turbotbird Offline
Senior Member
#8
got codes, theres some in these that I cant seem to erase...I got codes:
81: Turbo boost control circuit open
10: Separator code (means nothing)
14: PIP circuit failure
22: MAP/BARO > or < expected
42: Lack of HO2S swithces, rich bank 1
58: IAT above max voltage, Vane meter
66: VAF cicuit below min. voltage

I unpluged the vane meter while it was running, so thats probably why 58 is there, probably 66 too?
88 TC/HX35/CAI/3" exhaust/Wilson MS2/Beanman header/Head Work/Laramee Cam/Gillis boost controller/3G alt/Walboro 255 fuel pump/BOV/CHE rear control arms/1" lowered/poly. bushings/Chuck W mounts/6 puck clutch/Pro 5.0 shifter/AEM wideband/Tuning MS..
Reply

junkedturbo Offline
Senior Member
#9
Your code 14 is keeping your car from runnig, your going to need to buy a remaned distrbutor or a new TFI module forget witch one Sad

Code 66 is leading to the code 42, your going to have to test your vam when you get the time.

Dont know to much about BP sensors so I really cant help you with code 22, just try to fix the other to first and see if that code goes away if not your going to need to get another BP sensor.

I've never heard of codes 81, 10, or 58 but again I have an old chiltons manual I read my codes from Sad

I'm so full of sad faces today, I think its the wether by me?
Reply

BJL Offline
Moderator
#10
81 your boost control solenoid is disconnected
14 you have a bad PIP.. replace it most common symptom is the crazy idle your talking about
22 map/baro make sure its not hook up to a vacuum line.. may just be bad also.
42 most lilly result of code 22, dumping fuel and pulling it back.. confusing itself
58 and 66 also can be a result of cray idle...

when you replaced the PIP how did the metal pick up look? i had a pip code come and go till the car stalled and never restarted, the stator came off the dist shaft.....

most of your code seem to be related.... check you Baro sensor....soem people hook this to engine vacuum which is BAD! it sense barometric pressure....

keep us posted... check your basics too, vac lines... connections.. grounds..coolant level, oil level...
Brian Larkin
88TC 330,000 miles
Slightly Modified
Reply





Users browsing this thread:
1 Guest(s)



Theme © iAndrew 2018 - Software MyBB