North American Turbocoupe Organization



Still having ABS problems
beckettbird Offline
Junior Member
#1
I've been working on my ABS problem for awhile now--here's whats happened so far--
First off, i got both lights on and hard pedal symptoms. i originally took it to a place and they pulled a code 12 which was to replace the module. I bought a used one from a fellow member. i installed it and cleared the codes and everything was fine. The next day i was at th AF muesem and when I came out my battery was weak. I heard the hyd pump motor running--popped the hood and the relay was shorting out due to some stripped wires. Well, i fixed the wires and bought a new relay and that didn't work. i pulled the codes and got a 35 or 36. So i cleaned and did all the checks on them that the Chilton's manual stated and they both passed. Went back to the relay and jumped the pins to do the test and the hyd motor came on before I put the Ignition switch to run. however, i started the car and the the lights went out and everything was working fine. Put the relay back in and after a couple miles the problems back. My best guess now is that the pressure switch may be faulty. Since all the system was fine with the jumper wire, i figure the switch isn't telling the pump to come on. is there a simple test for the pressure switch before i buy a new one? Sorry so long!
Reply

Jeff K Offline
Administrator
#2
First of all, the ABS part of the braking system and the Electro-hydraulic power brake part of the system are 100% independant of each other.... in other words, both lights on and hard pedal had NOTHING to do with the code 12 from tha ABS computer. You can take the ABS computer, throw it in the trash, and you will still have power braking, just no ABS.


Can you tell me the color of the wires at the pump relay that were shorted out?

Pressure switch, etc: Pull 5 pin connector off switch. Turn key to run. Jumper the GY wire to the PK/LB wire in the connector. With these jumpered, pump relay should click on and pump should run. If relay doesnt click, you have a bad relay, or the relay coil isnt getting 12V in run on the GY/Y wire due to a blown fuse link N or a bad ignition switch or wiring problem between ig. sw. and relay, or the GY wire isnt grounded like it should be.

If relay clicks and pump runs when GY abd PK/LB are jumpered, relay, wiring, pump are OK. Turn key off, and pump brakes 10 or so times to bleed down accumulator pressure. Measure resistance between the pressure switch terminals corresponding to the GY and PK/LB wires. Should be zero ohms. If is more than a few ohms or an open circuit, the pressure switch is bad.

Codes 35 and 36 are for the LH and RH front sensors respectively. Check sensor resistance at the ABS computer connector to be sure they are around 1K to 2K ohms. If that checks out, connect a DMM on AC mV scale to sensor, and give wheel a spin. Should get 50 to a few hundred mV AC depending on how fast wheel is spinning.


------------------
Jeff Korn

88 Turbo Coupe: Intake and exhaust mods, T3 turbo at 21 psi, forced air intercooler, water injection, bypass valve, Ranger roller cam, subframes, etc., etc.. // 86 Tbird 5.0 (original owner): intake, exhaust, valvetrain mods, 100 HP nitrous, ignition, gears, suspension, etc., etc.... // 91 Escort: Bone stock winter car // 02 Taurus Vulcan(wifes car)
Jeff Korn

88 Turbo Coupe: Intake and exhaust mods, T3 turbo at 24 psi, forced air IC, water injection, BPV, Ranger cam, subframes, etc., etc.
86 Tbird 5.0 (original owner): intake, exhaust, valvetrain mods, 100 HP N2O, ignition, gears, suspension, etc., etc.
05 Taurus SEL Duratec daily driver
04 Taurus Duratec (wifes car)
02 Pontiac Grand Prix GT
95 Taurus GL Vulcan winter beater
67 Honda 450 Super Sport - completely customized
Reply

beckettbird Offline
Junior Member
#3
The solid green wire and the red wire with the blue stripe. The insulation was stripped back on the grey/red wire, but i don't think it was shorting.

I ran the continuity checks and the voltage checks on the wheel sensors and the circuits they came up fine.
Reply

Jeff K Offline
Administrator
#4
By red with blue stripe, I am guessing that is really the PK/LB wire. There isnt a green wire at the relay. The GY/R wire supplies 12V to the motor. Only way the motor coul cun constantly with the key off is the relay stuck shut, or the Gy/R wire shorted to the Tan/yellow wire. A GY/Y to GY/R short would run the motor thru the ignition switch with the key on only.

Are you sure you are reading the BAS code flashes correctly? They are, IMO, harder to count out compared to the EEC codes.

------------------
Jeff Korn

88 Turbo Coupe: Intake and exhaust mods, T3 turbo at 21 psi, forced air intercooler, water injection, bypass valve, Ranger roller cam, subframes, etc., etc.. // 86 Tbird 5.0 (original owner): intake, exhaust, valvetrain mods, 100 HP nitrous, ignition, gears, suspension, etc., etc.... // 91 Escort: Bone stock winter car // 02 Taurus Vulcan(wifes car)
Jeff Korn

88 Turbo Coupe: Intake and exhaust mods, T3 turbo at 24 psi, forced air IC, water injection, BPV, Ranger cam, subframes, etc., etc.
86 Tbird 5.0 (original owner): intake, exhaust, valvetrain mods, 100 HP N2O, ignition, gears, suspension, etc., etc.
05 Taurus SEL Duratec daily driver
04 Taurus Duratec (wifes car)
02 Pontiac Grand Prix GT
95 Taurus GL Vulcan winter beater
67 Honda 450 Super Sport - completely customized
Reply

beckettbird Offline
Junior Member
#5
I don't know what that wire is since its not shown on the wiring diagram?
I tried to attach a pic so you can see

With the codes, I jumpered the pins in the trunk and here.s what I get:
The lights come on then the ABS goes dark
then flash,flash,flash,dark for about 2 secs then flash,flash,flash,flash,flash, then steady on. I assume a 35 or 36.
Reply

beckettbird Offline
Junior Member
#6
Jeff,

Thanks for all your expert assistance with my problem. I ran the tests on the Pressure switch and I'm getting an open circuit, so i think a new pressure switch will fix the prob. Hopefully I can get a new one!
Reply





Users browsing this thread:
1 Guest(s)



Theme © iAndrew 2018 - Software MyBB