North American Turbocoupe Organization



Random high idle ?
glenn-tc88 Offline
Member
#11
when it idles high tap tps lightly and if it idles down its tps.  mine did same swapping tps fixed it.
Glenn Dembowski
2003 Mercury Marauder Black
1988 Thunderbird TC Sandalwood 5sp
1974 Harley Davidson FLH
1998 Chevrolet K1500
Reply

t c mike Offline
Junior Member
#12
(06-27-2020, 02:16 PM)glenn-tc88 Wrote: when it idles high tap tps lightly and if it idles down its tps.  mine did same swapping tps fixed it.
Thanks Glenn !!! Makes sense to me. Won't get to it till next week & wiil post results then.
Thanks again !
mike
Reply

vegas_ss Offline
Senior Member
#13
I get the random high idle occasionally... usually notice it happening after a freeway drive.  I do have a manual so it's not a big issue for me.  Usually shutting off and restarting cures the issue. Other times just driving a bit takes care of it.  I did replace the VAM about a year ago for a different issue, that didn't have any effect on the random high idle as it has been occurring for several years but not often enough for me to remember checking it out.  Getting old I also get forgetful Wink
1987 TC, 5sp, Boport Stage 3 Head/2.1 Cam
1996 Impala SS
Reply

BJL Offline
Moderator
#14
typical TPS getting a lil wacky. try resetting base TPS setting or buy a new TPS.
Brian J Larkin
88TC 320k miles
T3, FMIC ,3in stinger exhaust, gillis,
255 walbro, afpr, 5spd swap,spec clutch, sn95 5 lug,.
89 Cougar XR7 3.8SC Auto
95 Ranger Splash 3.0 auto
Reply

t c mike Offline
Junior Member
#15
(06-28-2020, 02:38 AM)BJL Wrote: typical TPS getting a lil wacky. try resetting base TPS setting or buy a new TPS.
Did the reset to .94 v as Jeff K suggested.....helped, but didn't last long. It idled fast when i had the hood up, tapped the tps as suggested & it came right down.My Ford dealer is getting me a new tps.
Thanks EVERYONE !!!!mike
Mikey97D, anasazi4st and BJL like this post
Reply

anasazi4st Offline
Senior Member
#16
(07-06-2020, 02:09 PM)t c mike Wrote:
(06-28-2020, 02:38 AM)BJL Wrote: typical TPS getting a lil wacky. try resetting base TPS setting or buy a new TPS.
Did the reset to .94 v as Jeff K suggested.....helped, but didn't last long. It idled fast when i had the hood up, tapped the tps as suggested & it came right down.My Ford dealer is getting me a new tps.
Thanks EVERYONE !!!!mike

Yeah sadly like so many, this pretty much has to be a Motorcraft part. I had problems with 3rd-party ones as well.
Another proud dues-paying member.

1987 Turbo Coupe w/T5OD, 8.8 axle, grey smoke; most options. Got it in 1991 with 41K miles: 3 turbos, 2 heater cores, 1 T5OD full rebuild, 5 clutches, 1 head gasket, 2 Teves II ABS units, etc. later....
Reply





Users browsing this thread:
1 Guest(s)



Theme © iAndrew 2018 - Software MyBB