North American Turbocoupe Organization



probems!
Harvs Offline
Senior Member
#1
I'm having a lot of problems in my 87' TC, one is my passenger side seat does not work, when u go to put it forward it does not move and the lights go dim, my driver side works sometimes,I changed the fuse and that did not help. Another problem is when I turn my car on the lights go on when the switch is off. I don't know if it is the ignition switch or what! My [email protected]*!ing turbo is shot. I have a Ric Gillis and the psi is about 17,I turned it down to see if that would help but NO,when I hit about 15 or so or when I floor it the turbo is very loud and the car bucks! all the hoses are on and there is on craks in the housing so if someone could help me, That would be great. Thanks.
Sandlewood beige 88 coupe 93k/ super 60 T3 at 24 pounds/ ATR 3" no cat or tail pipe/ 255lph high pressure pump/ Kirban AFPR at 42/ Spec stg3/ GN FMIC/ 1g DSM BOV/ 14* timing/ disconected KS/ Tri-ax short throw/ Autometer boost,vac and air to fuel/ 140 spedo/ Ford motorsports 5300-c springs/ tubular rear upper cntrl arms.
Reply

Walsted Offline
Posting Freak
#2
Quote:Originally posted by Harvs:
...Another problem is when I turn my car on the lights go on when the switch is off. I don't know if it is the ignition switch or what!
I don't suppose that there are a couple of rotary dials next to the light switch? If so, turn the dials all the way downward, and that will shut off the autolights. Otherwise, it is a short of some sort. Let us know if there are other light problems, such as fog lights or signals and we can go from there.

------------------
Mike Walsted - NATO member
1986 5-speed TurboCoupe and 1985 5-speed XR7
Mike Walsted - Sold my 1986 5-speed TurboCoupe
Reply

Pete D Offline
Administrator
#3
We need more info on the turbo. Why do you say it's shot? What do you mean by loud? Did you just install a K&N? When the car bucks is it like a spark miss or more like lack of fuel?

------------------
NATO Member. it's not a vice, it's an obsession
"The nice thing about each new day is nobody ever used it before" Barnaby Jones
88 TC X 2, 86 SVO, mods list at
http://www.turbotbird.com/showroom/pd_88tc.htm

[This message has been edited by Pete D (edited 08-10-2002).]
Pete Dunham


Reply

cougar5704 Offline
Junior Member
#4
On your seat problem sounds like the motor is stuck and dims the lights due to the draw of current to overcome the obstruction .Remove the seat , clean and lube the tracks and test the motor while you have the seat out . As far as the lights coming on when you start the car , if you have auto headlights , make sure you have not covered or unplug the photocell on the middle of dash or just turn the dial to off as sugested previously .
Reply

Mr. Sam Ford Offline
Senior Member
#5
On the turbo problem, it sounds to me like it could be a bad connection between turbo and intercooler. Double and triple check that the intercooler hoses are not split or folded over and the clamps are tight. The car would also be running really rich if this were the problem
'88 Thunderbird TC, daily headache with a few mods, 14.65 and still not happy Smile

'86 Mustang GT, daily transport, fresh 302, Twisted Wedge heads, Track Heat intake, custom cam, all the associated goodies, 4.10s, hoping for mid 12s n/a
Reply





Users browsing this thread:
1 Guest(s)



Theme © iAndrew 2018 - Software MyBB