North American Turbocoupe Organization



Prc codes
BJL Offline
Moderator
#1
For the life of me i cant find the article for checking prc codes. 
My tc hasnt had PRC since 2005. 
Im trying to help.a friend get his situated and im stuck. I dont have a instant answer like i normally do. 
Any body have a link or brief descriptions. Its flashing. He says 2 times. Then pauses. Then 4. But i not 100% till im in front of it. 
Thanks guys!
Brian J Larkin
88TC 328,000 miles
T3, FMIC ,3in stinger exhaust, PimpXS ECC,gillis,
255 walbro, afpr, 5spd swap,spec clutch, sn95 5 lug, Cobra 13in front brake. Vacuum assist brake conversion. 
89 Cougar XR7 3.8SC Auto
95 Ranger Splash 3.0 auto
Reply

ThorJrTurbo Offline
Junior Member
#2
(03-19-2021, 01:25 AM)BJL Wrote: For the life of me i cant find the article for checking prc codes. 
My tc hasnt had PRC since 2005. 
Im trying to help.a friend get his situated and im stuck. I dont have a instant answer like i normally do. 
Any body have a link or brief descriptions. Its flashing. He says 2 times. Then pauses. Then 4. But i not 100% till im in front of it. 
Thanks guys!

Programmed Ride Control Problems - by Jeff Korn Question: The Programmed Ride Control on my 87-88 Turbo Coupe doesn’t seem to be working correctly and / or the green PRC FIRM light is flashing. Answer: If the PRC computer detects a fault in the system, it will flash the FIRM light. The PRC computer can be put into a self diagnostic mode just like the EEC can. To enter the PRC self test mode, do this: Remove the ash tray and locate the two terminal connector right under the ash tray. Fabricate a wire, like a bent paper clip, and jumper the two terminals on the connector. Be sure the PRC switch is set in the AUTO RIDE position, and start the car. Within 20 seconds of starting the car, remove the jumper wire, and watch the PRC FIRM light. Count the blinks of the firm light. The light will blink the same code 4 times, once every 9 seconds. Here is a brief explanation of the codes: Code 1- Fault in LH rear activator circuit, 2 - Fault in RH rear activator circuit, 3 - Fault in RH front activator circuit, 4 - Fault in LH front activator circuit, 5 – Short in soft shock relay control, 7 – Replace PRC computer, 13 – Short in hard relay control, 14 – Fault in relay control circuit, 6 – no problem yet…. Further diagnostic work needed. The Ford shop manual contains a detailed troubleshooting procedure for each code, which is impractical to reproduce here. If specific information is needed, ask on the message board, and someone should be able to give you the troubleshooting details. Question: The Programmed Ride Control on my 87-88 Turbo Coupe doesn’t stay on FIRM all the time when I put the switch in the FIRM position. Answer: The most likely cause of this problem is a bad AUTO / FIRM switch. Before replacing the switch, try to clean it by blasting it liberally from both the front and back with electrical contact cleaner (available at Radio Shack) while working the switch between positions. Many times this will fix the problem. If the switch still doesn’t work, it is possible to take the switch apart and clean the contacts, and reassemble the switch, but if you try this, watch out for small springs and balls that may fly out of the switch. If you want to replace the switch with a new one, (if you can find a Ford dealer that actually has one), you will be in for a shock, as the switch is only sold as part of the whole assembly which includes the REG/ PREM fuel switch, power antenna switch, and the switch panel. The switch and panel assembly costs in excess of $100. Programmed Ride Control Actuator Repair - by Don H. I found that the actuators get stuck internally. The actuator is a small reversible motor. When the programmed ride control calls for firm or soft settings voltage is applied to spin a rotor about 90 degrees. This happens so quickly they put little rubber bumpers inside the actuators to stop the rotor movement and absorb the shock of it turning. The little rubber bumpers turn to goo inside and the rotor gets stuck at the firm or soft setting. You have to remover the actuator from the top of the shock by squeezing the white plastic retainer. Once off and disconnected carefully pry up the two metal tabs on the wire retaining clip and remove the clip. Next, pry up the tabs holding the case of the actuator together and separate the case. Inside you will find the rotor, a wire wound disk. Remove this and clean the black goo off the rotor and inside the case under the magnets. Thoroughly clean the contacts on the underside of the rotor and the semi circular contact in the case. These may be burned at one end or the other, so get that all off. The two dissolved rubber bumpers have to be replaced with firm rubber 5/16 inch long. I cut pieces of vacuum hose that length, and cutting that piece into thirds along the length. The whole idea is to get the proper length bumper in place. When you take the actuator apart, the problem and the solution will be more obvious than I can describe.
Turbo Coupe For Life

1987 Turbo Coupe, Black, 5 Speed, K&N, RR cam
Reply

ThorJrTurbo Offline
Junior Member
#3
Sorry so long. I wanted to make sure you received all the info. This is a old thread but some great info.
Turbo Coupe For Life

1987 Turbo Coupe, Black, 5 Speed, K&N, RR cam
Reply

anasazi4st Offline
Senior Member
#4
(03-24-2021, 03:33 PM)ThorJrTurbo Wrote: Sorry so long. I wanted to make sure you received all the info. This is a old thread but some great info.

Thanks for coming through, ThorJrTurbo! I was searching old posts for BJL’s answer, did not occur to me to look at the FAQs.

Smile Exclamation
Another proud dues-paying member.

1987 Turbo Coupe w/T5OD, 8.8 axle, grey smoke; most options. Got it in 1991 with 41K miles: 3 turbos, 2 heater cores, 1 T5OD full rebuild, 5 clutches, 1 head gasket, 2 Teves II ABS units, etc. later....
Reply

BJL Offline
Moderator
#5
nice i looked through most of those! thanks! I just did the old swap the the actuator test, led me back to LF, code 4. thanks again!
great find, where was it listed under? i searched a few times and couldnt find it. maybe on the old site.
i blame this on andrewjs18 for moving everything around...
Brian J Larkin
88TC 328,000 miles
T3, FMIC ,3in stinger exhaust, PimpXS ECC,gillis,
255 walbro, afpr, 5spd swap,spec clutch, sn95 5 lug, Cobra 13in front brake. Vacuum assist brake conversion. 
89 Cougar XR7 3.8SC Auto
95 Ranger Splash 3.0 auto
Reply

ThorJrTurbo Offline
Junior Member
#6
(03-25-2021, 02:43 PM)BJL Wrote: nice i looked through most of those! thanks! I just did the old swap the the actuator test, led me back to LF, code 4. thanks again!
great find, where was it listed under? i searched a few times and couldnt find it. maybe on the old site.
i blame this on andrewjs18 for moving everything around...

I found it on the old website in the FAQ. I loved the new and improved website but the nothing is like the old one!!! LOL.
Turbo Coupe For Life

1987 Turbo Coupe, Black, 5 Speed, K&N, RR cam
Reply

ThorJrTurbo Offline
Junior Member
#7
(03-25-2021, 11:02 AM)anasazi4st Wrote:
(03-24-2021, 03:33 PM)ThorJrTurbo Wrote: Sorry so long. I wanted to make sure you received all the info. This is a old thread but some great info.

Thanks for coming through, ThorJrTurbo! I was searching old posts for BJL’s answer, did not occur to me to look at the FAQs.

Smile Exclamation

You are welcome. It did take me a while to remember where I did see this. The old website has so many gems!!!
Turbo Coupe For Life

1987 Turbo Coupe, Black, 5 Speed, K&N, RR cam
Reply





Users browsing this thread:
1 Guest(s)



Theme © iAndrew 2018 - Software MyBB