North American Turbocoupe Organization



Oxidized or clearcoat chip?
MeAndMyT Offline
Senior Member
#1
Ok so the rims are oxidized or maybe just the clearcoat is chipping whatever it is its kinda of a brownish tan color? So i figured i could go buy something that could take the clearcoat off the rim and polish them up a bit.. But would they just corrode again within a couple months? Would i have to reclear them? If so how much does reclearing estimatly cost?

Now getting off the topic i just replaced the clutch in my TC and i think i forgot to plug in one of the wires that plug into the trans. Now my speedo doesnt work and milelage is not going up.. I just thought that maybe people could do this when they bought there car and Rip somone off with false mileage.. I just thought it was kinda funny..

Have a good day everyone and thanks for the help as always..

Vince.
88 TC 5 spd 22x,xxx miles Ran 15.3 in 1/4.. K&N Cone. Gillis boost controller @ 15. Faze Boost Gauge. A/C belt off. 2 1/2 inch exhaust dumped at axles.
Reply

Pete D Offline
Administrator
#2
If the wheels are not cleared, they will oxidise/corrode

You might want to check out this article;
http://www.foxthundercats.com/tech/wheelrestoration.htm

There are several posts on this subject. Search on "polished wheel"
http://natomessageboard.com/cgi-bin/ulti...031#000000
http://natomessageboard.com/cgi-bin/ulti...116#000006

There are many more.
Pete Dunham


Reply

bhazard Offline
Posting Freak
#3
I used the airplane stripper stuff they sell at autozone, it was nice, it took the nasty clearcoat right off. I was only able to do two wheels though, but they looked a lot better even with just the clear gone.

Sometime when it warms back up I would like to get a couple more cans and get all the wheels completely stripped. I think I will end up painting them though.
88 TC, 170k, K&N, $5 Boostvalve, Stinger 3" ex., 3" Magnaflow, 3" Stinger tail, Zoom clutch
15.26 @ 86mph, 2.18 60' killed valvetrain & headgasket
Reply

Jeff K Offline
Administrator
#4
Sounds like you forgot to plug the VSS into the harness at the tranny. Plug it in, and the speedo and odometer should start to work.
Jeff Korn

88 Turbo Coupe: Intake and exhaust mods, T3 turbo at 24 psi, forced air IC, water injection, BPV, Ranger cam, subframes, etc., etc.
86 Tbird 5.0 (original owner): intake, exhaust, valvetrain mods, 100 HP N2O, ignition, gears, suspension, etc., etc.
05 Taurus SEL Duratec daily driver
04 Taurus Duratec (wifes car)
02 Pontiac Grand Prix GT
95 Taurus GL Vulcan winter beater
67 Honda 450 Super Sport - completely customized
Reply

MeAndMyT Offline
Senior Member
#5
yes that was the problem i remember pluggin it back in but i didnt plug it in all the way it goes in kinda of weird and i didnt make sure that it was all the way in.. Thanks for info everyone.
88 TC 5 spd 22x,xxx miles Ran 15.3 in 1/4.. K&N Cone. Gillis boost controller @ 15. Faze Boost Gauge. A/C belt off. 2 1/2 inch exhaust dumped at axles.
Reply





Users browsing this thread:
1 Guest(s)



Theme © iAndrew 2018 - Software MyBB