North American Turbocoupe Organization



oil pres.guage
mike65 Offline
Member
#1
ok i,ve asked about this guage before,mine seems to read lower than it used to,and it doesnt move at all when i hit the gas or slow down it just moves up to just below "1/2" when i start the car and stays right there or sometimes drops a little,I notice on other cars they move with the gas pedal being pushed,could my sending unit be taking a dive??
Reply

Turbobob_dup1 Offline
Member
#2
Most likey. Those electronic units aren't the most reliable anyway.
Drop in a new one and away you go [Image: wink.gif] They're not very expensive.

------------------
More Boost!!
'87 turbocoupe finally done!! Pics soon.
87 Turbocoupe,T3/T4 turbo,much porting,AFPR,255lph pump,GN cooler,K&N in fender,gutted upper/knifed lower,big valve head,A237 cam ,60mm throttle body,Talon 1G BPV.
4 + 1 = 8!!
Reply

mike65 Offline
Member
#3
Turbobob,the guage in the car is not the electronic one,regular guage,but i did figure maybe its just time to replace,thanks
Reply

mike65 Offline
Member
#4
Also dont i just need to replace the sending unit??
Reply

Turbobob_dup1 Offline
Member
#5
Sorry that's what I ment..sometimes I just get off on a tangent.

If it has a sending unit then it is electric. A mechanical one has a line hooked up to the same location the electric one is at and actually send a small bit of oil into the guage to read the pressure. [Image: smile.gif]

------------------
More Boost!!
'87 turbocoupe finally done!! Pics soon.
87 Turbocoupe,T3/T4 turbo,much porting,AFPR,255lph pump,GN cooler,K&N in fender,gutted upper/knifed lower,big valve head,A237 cam ,60mm throttle body,Talon 1G BPV.
4 + 1 = 8!!
Reply

mike65 Offline
Member
#6
So oin other words,I just need to replace the sending unit??
Reply





Users browsing this thread:
1 Guest(s)



Theme © iAndrew 2018 - Software MyBB