North American Turbocoupe Organization



No Reverse Lights
Cerebral Offline
Senior Member
#1
I just got to work, and noticed that neither one of my reverse lights are working. Where is the sensor for it? Suggestions?
1987 Automatic TC- parts car

1987 5 Speed TC, K&N on Vam,Boost controller, T3, Bob's Log, Stinger 3 inch exhaust with Magnaflow, FMIC, Forge Dual Piston B.O.V., Ranger Roller, Esslinger Adjustable Pulley, Boport Drop in Valve Springs, Pyro Pete Clutch
Reply

Scott Mabe Offline
Member
#2
If your turn signals also do not work then It is most likely a blown fuse, if that's not it iirc the sensor is toward the rear of the transmission.
1987 Turbo Coupe
1988 Thunderbird parts car/ possibly street/strip car
1990 F-250HD 460ci
2001 Pontiac Montana (wife's ride)

-PLEASE FORGIVE TYPOS, I USE SWYPE ON MY PHONE-
Reply

Jeff K Offline
Administrator
#3
Check the easy things first. Are you sure both bulbs arent burned out?
Jeff Korn

88 Turbo Coupe: Intake and exhaust mods, T3 turbo at 24 psi, forced air IC, water injection, BPV, Ranger cam, subframes, etc., etc.
86 Tbird 5.0 (original owner): intake, exhaust, valvetrain mods, 100 HP N2O, ignition, gears, suspension, etc., etc.
05 Taurus SEL Duratec daily driver
04 Taurus Duratec (wifes car)
02 Pontiac Grand Prix GT
95 Taurus GL Vulcan winter beater
67 Honda 450 Super Sport - completely customized
Reply

Cerebral Offline
Senior Member
#4
Light bulbs check out. Turn signals work, is there a test for that switch?
1987 Automatic TC- parts car

1987 5 Speed TC, K&N on Vam,Boost controller, T3, Bob's Log, Stinger 3 inch exhaust with Magnaflow, FMIC, Forge Dual Piston B.O.V., Ranger Roller, Esslinger Adjustable Pulley, Boport Drop in Valve Springs, Pyro Pete Clutch
Reply





Users browsing this thread:
1 Guest(s)



Theme © iAndrew 2018 - Software MyBB