North American Turbocoupe Organization



MPG
goodstuff84 Offline
Member
#1
hey just wondering what everybody else was getting for gas mileage? i have an 88 TC with a 5 speed and i do about 75% highway and 25% city roughly and im getting an average of 19 mpg, i do like to play in the boost here and there but for the most part its just cruising at 70 to work and back. does this sound about right for this car?
Justin
88 TC, E-bay 50 trim t3/t4, ported E6, Volvo FMIC, Forge BPV, walbro 255 HP pump, Kirban AFPR, RAM clutch, full 3" stinger single exhaust w/dynomax muffler & dumped at axle, K&N cone on the VAM, *13 base timing, boost @ 20psi. http://s661.photobucket.com/albums/uu337/Goodstuff84/
Reply

Spooler87 Offline
Posting Freak
#2
I don't keep my foot out of it,

But now that it's actually running a bit better and has a fresh tune up, i get about 20-22 Most of the time. If I keep out of boost, slowly accel and decel, and coast down hills, I've gotten around 28-30 tops.
All hail Project "Marauder" !
Reply

Pete D Offline
Administrator
#3
Stay out of the boost for a week and see what changes?? 19 seems a little low for 75% highway. How old are the plugs?
Pete Dunham


Reply

cnpowell Offline
Senior Member
#4
I was getting about 30 mpg on the highway and about 24 around town with an auto tranny. That's normal driving .... no heavy right foot!!!!!
Carl (cnpowell)
No TC at the moment .... planning to get another in '18
Reply

Nsw Offline
Senior Member
#5
my average is around 22 mpg. highway mpg is probably 30 at about 130kmph. i dont get into the boost that much.
1988 5speed black every option. 3inch single turbo to tail(stinger), manual boost control. k&n cone walbro fuel pump

1986 xr4ti project car..... way to many mods to list.
Reply

tr_guy79 Offline
Senior Member
#6
I get 28-29 cruising at 70-75 on the hwy with the air on. Keep in mind that anytime you are in the boost, or above 3k rpm you will lose some mpg. I am searching for a trip minder to help me fine tune my driving habits. There is a point of diminishing returns when it comes to keep the revs low...
3rd Annual Philly Tri-State NATO Meet - http://natomessageboard.com/ultimatebb.p...p=1#000003

'87 - Range Roller 4* adv / 50 trim t04e / Ported E6 / Gutted Knifed intake / Stinger 3->2.5" / Adj. Cam Pulley / Warlboro 255

To Do: PIMP/MS2, FMIC, Bigger Inj
Reply

firstsvo Offline
Senior Member
#7
I have 2 of these. One auto and 1 stick. If I'm lucky they'll break 20 mpg. I'm not lucky all that often.
White '88 auto mostly stock, Black '88 5 speed nowhere near stock
Reply

BirdJunkie Offline
Senior Member
#8
on the highway from n.c to n.y I got 33mpg. I have seen other posts that say when you run over 3000 rpms the computer goes to a rich condition.so that may be why yours is low.
88 TC 5SPD BLACK MY BABY ORIG.OWNER(garage queen)/06 GTO 6SPD RED WIFES CAR(cop magnet...lol)/2011 TAHOE WHITE (wifes daily driver a.k.a Fifty Cent)/2016 SUPER DUTY RED(my daily driver a.k.a BIG red)/06 HAYABUSA (SEXY BITCH)..STATEFARM LUVS ME. ----N.A.T.O Bad Boy Division President----
Reply

tr_guy79 Offline
Senior Member
#9
My MPG probably has something to do with the K&N and open exhaust, between the two, that is probably good for about 1-2 mpg on the hwy, but having trouble breaking into the 20's would have me concerned. That is unless you have a heavy right foot
3rd Annual Philly Tri-State NATO Meet - http://natomessageboard.com/ultimatebb.p...p=1#000003

'87 - Range Roller 4* adv / 50 trim t04e / Ported E6 / Gutted Knifed intake / Stinger 3->2.5" / Adj. Cam Pulley / Warlboro 255

To Do: PIMP/MS2, FMIC, Bigger Inj
Reply

goodstuff84 Offline
Member
#10
i actually was driving the car really easy, hardly saw any boost at all for a full tank because i was specifically trying to see what i was getting for gas mileage, never saw over 70mph on the highway which is like 2700rpms? roughly. so this is leading me to think something is wrong. i had some idle issues and i did the TPS calibration thing from the write up thats on here and i got the baseline voltage set at .93 volts. but i still have some idle fluxuation. i cleaned out the IAC and it still seems to move freely and was fairly clean inside. so even though my TPS voltage is where it should be and there are no dead spots could it still be bad? i love this car but the 19mpg is killing me, its my daily driver and i do roughly 500 miles a week
Justin
88 TC, E-bay 50 trim t3/t4, ported E6, Volvo FMIC, Forge BPV, walbro 255 HP pump, Kirban AFPR, RAM clutch, full 3" stinger single exhaust w/dynomax muffler & dumped at axle, K&N cone on the VAM, *13 base timing, boost @ 20psi. http://s661.photobucket.com/albums/uu337/Goodstuff84/
Reply





Users browsing this thread:
1 Guest(s)



Theme © iAndrew 2018 - Software MyBB