North American Turbocoupe Organization



manual A/C blower control question
THOR 50 Offline
Member
#1
Have a non-climate control A/C system (mechanical). The fan speed control has 3 speeds and a dead spot. Postions are off low, dead spot, medium and high.
Does the fan have 4 speeds and is this the switch or the fan motor?
Reply

Pete D Offline
Administrator
#2
The manual fan SWITCH has 4 postions: Lo, M1, M2 and Hi
Pete Dunham


Reply

THOR 50 Offline
Member
#3
Pete,
Is this caused by the switch or the fan motor?
I've got one of the medium positions out.
Reply

fiveliter8 Offline
Senior Member
#4
It could be the switch or the blower resistor. I've had both instances happen. In one of my mustangs, the back of the switch showed signs of extreme overheating and the contacts were burned in two-replaced switch. In my bird, the blower resistor had a resistor coil burned in two-replaced it. Both are fairly easy to do. Don't worry, it's not your motor. [Image: smile.gif]

------------------
www.stangnut.com
1988 Tcoupe
1984 20th Anniversary GT350 Mustang 'Vert
1984 Mustang GT T-roof
1965 Shelby Cobra Replica
www.stangnut.com
1988Tcoupe-ye will be missed
'09 Flex SEL
1984 20th Anniversary GT350 Mustang 'Vert
1984 Mustang GT T-roof
1965 Shelby Cobra Replica
Reply

TurboE Offline
Posting Freak
#5
I guess i have a similar problem, at least i think. I don't seem to have HIGH speed. Should there be close to as much flow as a newer car. If it supposed to then i must not have the HIGH speed?
-88 TC Black
5spd, Precision SC50 T3/T4, QH/SD Tune, Gillis, AFPR, 255FP, WB O2, K&N, Ported E6, 3" DP, ATR 2.5" Duals, 3:73 Rear, Konis, Eibachs, 18" Voxx Wheels, X Drilled Rotors.
-06 G35 Coupe Diamond Graphite
-97 Pathfinder
Reply





Users browsing this thread:
1 Guest(s)



Theme © iAndrew 2018 - Software MyBB