North American Turbocoupe Organization



Lacks power on Acceleration
Bcountry44 Offline
Junior Member
#1
Hey guys,

I got a new turbo recently and now for some reason it feels like at around 4500 rpm the car has a governer, like its running on 3 cylinders or something. The turbo spools and boosts so I'm thinking fuel or computer issues. Any ideas on how to trouble shoot this? Thanks
Reply

Pete D Offline
Administrator
#2
Pull the codes - see the Technical Articles
It might be a sensor issue, doubtful it is the actual computer.

Run the fuel system diagnostics - see the TAs

what kind of spark plug wires are on it?

------------------
NATO Member. it's not a vice, it's an obsession
everyone has a photographic memory. Some, like me, just don't have any film.
Learn from the mistakes of others. Trust me... you can't live long enough to make them all yourself, I've tried!

88 TC, 86 SVO, 04 Escape. Mods list at
http://www.turbotbird.com/showroom/pd_88tc.htm
Pete Dunham


Reply

Fox ThunderCats Offline
Member
#3
My car lacks power, too. I think it's cuz it's got the lo-po 5.0 'twixt the fenders [Image: biggrin.gif]

------------------
Sam's Fox ThunderCats ... Your home on the web for fox Thunderbirds and Cougars
Sam's Fox ThunderCats ... Your home on the web for fox Thunderbirds and Cougars
Reply

Chad88TC Offline
Member
#4
What happens when you shift to another gear after this happens? Runs real choppy? How much boost you running?
'88 Black, K&N on VAM, Holset HY35, ported E6, 2.5" single cat-back w/dynomax muffler, gillis, RR cam, TA cam gear, Bosch BPV, Stock IC, Walbro 255HP, Kirban AFPR
Reply

Blue88TC Offline
Member
#5
how'll bout that timing?

------------------
88 Turbo Coupe,3"DP,3" Race Pipe,custom Y-pipe,Dynomax Ultra Flows,2.5" ATR SS Tailpipes,K&N filter,Gillis Valve,255 HP Fuel Pump,Kirban AFPR,Ported upper and lower intakes,HKS SSQ BOV,ported e6,[email protected],eec tuner. Spec stage 1 clutch,46# injectors awaiting install!
1988 turbo coupe, ported head, big valves, RW #1 cam, adj cam gear, front mount, ported intake, gillis, k&n cone, exhaust
Reply

Bcountry44 Offline
Junior Member
#6
I never got a check engine light so I'll go ahead and check for codes anyway. Running stock boost right now. Thanks
B.C.
Reply





Users browsing this thread:
1 Guest(s)



Theme © iAndrew 2018 - Software MyBB