North American Turbocoupe Organization



Issues since upgrades
BillB Offline
Junior Member
#1
Hey guys, I am a little baffled by my cars car's performance since upgrading the turbo, manifold and doing a front mount intercooler. My car will not pull past half throttle. If I accelerate prior bff o half throttle it will only make 6psi of boost and that's it. It I put it to half throttle or more it just falls on it's its face. I have put new plugs and wires on it as well. I don't know if the car needs bigger injectors or what. Any help would be greatly appreciated.
Reply

T`s ol fords Offline
Junior Member
#2
did you upgrade your fuel pump in the gas tank? mine had the fuel line attached to the pump crack and the car was starving for fuel. check your plugs for color if they are white the motor is running lean. i would check this first. if this is the case stay out of the gas or you can burn a hole in the piston. t`s
Reply

Jeff K Offline
Administrator
#3
Sounds like you may have a boost pressure leak. Check all connections for tightness, rubber tubing folded over, etc.

Do you have a WBO2? If so, what re the air/fuel ratios looking like?
Jeff Korn

88 Turbo Coupe: Intake and exhaust mods, T3 turbo at 24 psi, forced air IC, water injection, BPV, Ranger cam, subframes, etc., etc.
86 Tbird 5.0 (original owner): intake, exhaust, valvetrain mods, 100 HP N2O, ignition, gears, suspension, etc., etc.
05 Taurus SEL Duratec daily driver
04 Taurus Duratec (wifes car)
02 Pontiac Grand Prix GT
95 Taurus GL Vulcan winter beater
67 Honda 450 Super Sport - completely customized
Reply





Users browsing this thread:
1 Guest(s)



Theme © iAndrew 2018 - Software MyBB