North American Turbocoupe Organization



im ready to sell it :(
turbocoupeterry Offline
Member
#1
ive checked almost everything today with the car, i got it running but only if i hold the gas down and then it has absoulutly no power, i checked the timing and with the spout un-plugged its at 12 btdc and plugged in its about 40 is this right, fuel pressure is at 39 psi got good sparkl but i haver no power and once i let go of the gas it dies i pulled the code key on engine off codes only i got a code 67 ans 23 im going to check compression tomorrow ne other suggestions thanks for ne help terry
i forgot to mention it starts for a few seconds and then dies unless i push the gas

[This message has been edited by turbocoupeterry (edited 06-24-2001).]
88 tc, new tires and a k&n filter fender mounted
Reply

GT350R Offline
Senior Member
#2
The code 23(TPS sensor) could do it but I doubt it. If I were you I would check the cam timing and drop the down pipe t see if the cat converter is clogged.

------------------
GT350R
#1978 20th 2.3 Turbo T-top
#3608 20th 2.3 Turbo T-top
1985.5 TC
1987 TC 5 speed
1987 TC auto
1988 TC auto
1983 Mustang soon to be Turbo


My Garage
GT350R
(sold Sad ) 87 5speed, Motorsport head, [email protected]+2, [email protected], gutted or ported everything & all the typical junk.
84 Gt350 2.3T T-top
84 Turbo GT 418rwhp

My Garage
Reply

turbocoupeterry Offline
Member
#3
ill check the cam timing tomorrow but im positive it's not the cat (i know its there but its not clogged its one of those new ones that is right inside the pipe so you cant see it) but the cam timing is a good [place to start which would explain the noise in the motor
88 tc, new tires and a k&n filter fender mounted
Reply

Blade1433 Offline
Senior Member
#4
DON'T SELL IT! My Amigo was doing the same freaking thing last week, caused me to be late to work two days in a row. Don't want to make you seem like an idiot, but have you checked for water in the gas tank? It was the LAST thing we looked at on the Amigo. It turned out to be a hole rusted in the filler tube, last week when it rained I had hit a big puddle around the corner from my house. We spent hours trying to find the problem, drained the tank as a last resort. ONLY about a gallon of gas at the bottom. We also found out that the Amigo likes gas better than water. It's always the simplist things, ain't it?


James
Reply

DennySweet Offline
Member
#5
Mine did the same thing. When you get it running does it blow out black smoke? Mine did and all it was is the hose from the turbo to the intercooler was folded up in back where it can't be seen. I put grease on the inside of the hose to stop this.
88TC,87TC,,86S-10,82Toyota 4WD,3-88S-10Blazers.
Reply

Jeff K Offline
Administrator
#6
I agree with a major vac leak somewhere. Check the turbo to IC and IC to throttle body hoses to be sure they are on correctly and dont have any rips. Also be sure the VAM to turbo hose is tight and in good shape. A bad TPS will often make the car idle funny, surge / buck at speed, but usually wont make it run as bad as yours is.

------------------
Jeff Korn

88 Turbo Coupe: Intake and exhaust mods, T3 turbo at 20 psi, forced air intercooler, water injection, bypass valve, Ranger roller cam, subframes, etc., etc.. // 86 Tbird 5.0 (original owner): intake, exhaust, valvetrain mods, 100 HP nitrous, ignition, gears, suspension, etc., etc.... // 91 Escort: Bone stock winter car // 00 Windstar (wifes vehicle)
Jeff Korn

88 Turbo Coupe: Intake and exhaust mods, T3 turbo at 24 psi, forced air IC, water injection, BPV, Ranger cam, subframes, etc., etc.
86 Tbird 5.0 (original owner): intake, exhaust, valvetrain mods, 100 HP N2O, ignition, gears, suspension, etc., etc.
05 Taurus SEL Duratec daily driver
04 Taurus Duratec (wifes car)
02 Pontiac Grand Prix GT
95 Taurus GL Vulcan winter beater
67 Honda 450 Super Sport - completely customized
Reply

Pete D Offline
Administrator
#7
Denny, be careful that grease on the IC hose doesn't get you under boost. It may boost off. It probably does help to keep it from folding in on itself, but it may sooner or later let the hose come off after a few trips to the boost godess.

------------------
88 TC X 2, 86 SVO, Main TC with K&N, 3"DP to 2.5"duals through Dynamax, Ric valve at 17+ and disconnected KS.
Elite Bodega 16" chrome wheels. Autometer pod w/ A/F and Vac/boost gauges. New engine shortly, ported head and
manifolds, polished and cc'd chambers, A-230 cam, Race Engineering Adj Cam Sprocket, Crowlers, ARP head studs, Walbro 190 pump and T-3 for starters. KB subs
and jack rails.
Pete Dunham


Reply

turbocoupeterry Offline
Member
#8
well the gas tank is full and it held 16 gallons, and the car ran fine when mybuddy drove it 20 miles out of town and came back then it started doing it so i dont know if he did somewthing to it or what he says he kept it at 55 but hes got a lead foot and with a turbo you cant resist so im not sure yet, theres no black smoke, and the timing is correct so, it happend when i drove up-town real quick it started losing power i hads to crawl home and getting it to move out of first gear was a #$%@! it didnt want to move im checking more out on it today well see.
88 tc, new tires and a k&n filter fender mounted
Reply

turbocoupeterry Offline
Member
#9
well i got her running half ass today it idles fine by itself but when i checkd the timing with the spout out it was fine adn the ni put the spout in and it was reading like 40 btdc is this right i tought it was supposed to be something like 30, ne i really have to give it gas to get moving in gear once im going though its fine not a whole lot of pickup but enough to crise down the road and now ive got funny sounds coming from the cam cover same sound as before time for a new cam and followers maybe, ne advice everything else checks out fine
88 tc, new tires and a k&n filter fender mounted
Reply

JONESER Offline
Senior Member
#10
Try to unplug the VAM.
It won't idle for shit unless you turn up the idle screw. With it unplugged, take it for a run. My car acted like that and it was the VAM. I unhooked it, turned up the idle screw to get it to idle and drove it like that for a few weeks until I got the $$$ for a new one ($100).
It will get real bad gas milage, but you should have all the power back.
OR
It could be your CAT.
Good Luck
87 Turbo Coupe, 5-speed, boost at 18 PSI, K&N in finder, tangerine paint, shaved door handles, locks and emblems, painted interior trim(same as exterior), tiger print headliner, visors and door panels, Autometer gauges, 5.6" monitor & Playstation 2, lowered, white pony wheels...did I forget anything?
Reply





Users browsing this thread:
1 Guest(s)



Theme © iAndrew 2018 - Software MyBB