North American Turbocoupe Organization



ignition switch
Michael Hopper Offline
Junior Member
#1
HI Fellas For some time now my car will turn over but not run so i jumperd the starter sylinoid to batt positiv and the car would run then at times it would run without the jumper.Lately my power brack assist went out doing a search on brack prob i found out these are symptoms of bad ignition switch,So i replased it.but they still dont work.My keys come out while car is runing could this be it[bad lock sylinder].Its said u are suposed to put key in run position when instaling ig swittch,but new ign switch apeared to be in off position.Any suggjestions would be apresiated p.s could some one tell me what ign wires go to what THANKSSSS as always MIKE
88
Reply

Pete D Offline
Administrator
#2
check your email on the wiring diagram. If the switch doesn't cure the power brake problem, see
http://www.turbotbird.com/techinfo/TEVES...%20TCs.htm

See the section about the booster relay
Pete Dunham


Reply

Jeff K Offline
Administrator
#3
As noted in the article Pete quoted, if the power brakes AND the gauges dont work / went out at the same time, then the problem is a bad ig. sw.
Jeff Korn

88 Turbo Coupe: Intake and exhaust mods, T3 turbo at 24 psi, forced air IC, water injection, BPV, Ranger cam, subframes, etc., etc.
86 Tbird 5.0 (original owner): intake, exhaust, valvetrain mods, 100 HP N2O, ignition, gears, suspension, etc., etc.
05 Taurus SEL Duratec daily driver
04 Taurus Duratec (wifes car)
02 Pontiac Grand Prix GT
95 Taurus GL Vulcan winter beater
67 Honda 450 Super Sport - completely customized
Reply





Users browsing this thread:
1 Guest(s)



Theme © iAndrew 2018 - Software MyBB