North American Turbocoupe Organization



If not alternator, what could it be?
John B Offline
Member
#1
So I was driving my 88 TC last weekend and noticed that it was running a little rough. I drove to my parent's house, shut off the car and went to immediately start it again and got the "slow crank, battery is dead". I attached my battery charger and the car did turn over and start but once I removed the charger the voltage started to drop immediately. I'm running a PimpX ECU so I was watching the voltage gauge on the laptop. My immediate thought was the alternator is not charging the system. I'm running a PA Performance 3G alternator and have it wired as outlined in the tech guide on this forum. I removed the alternator and had it tested at Autozone. They said the alternator failed all tests so I shipped it to PA Performance. PA Performance reached out today and said the alternator is passing all of their tests just fine (taking their word over autozone) so my question is what could the problem be? The battery is two years old so I don't think that would be the problem but could it? I haven't checked it yet. PA Performance also sent me a diagnostic sheet that suggests comparing the voltage at battery versus alternator output post, and checking the voltage readings of the individual wires on the 3 wire regulator plug. Any other ideas out there? Thanks everyone
88 Turbo Coupe: Front mount intercooler, MGW short throw shifter, full coilover conversion, tubular control arms front and rear, svo front brakes, vacuum assist brake swap, manual steering swap, GT35R turbo with external gate, pimpx ecu, 60lb injectors, 3 core aluminum radiator, corbeau fixed back seats, and the list goes on.
Reply

Jeff K Offline
Administrator
#2
Engine to frame ground strap intact and solid connections at both ends?

Possible issue with the regulator plug, or regulator circuits as PA suggested. Check voltages and be sure to use a test light on any circuits that supply any amps.
Jeff Korn

88 Turbo Coupe: Intake and exhaust mods, T3 turbo at 24 psi, forced air IC, water injection, BPV, Ranger cam, subframes, etc., etc.
86 Tbird 5.0 (original owner): intake, exhaust, valvetrain mods, 100 HP N2O, ignition, gears, suspension, etc., etc.
05 Taurus SEL Duratec daily driver
04 Taurus Duratec (wifes car)
02 Pontiac Grand Prix GT
95 Taurus GL Vulcan winter beater
67 Honda 450 Super Sport - completely customized
Reply

John B Offline
Member
#3
Jeff K Wrote:Engine to frame ground strap intact and solid connections at both ends?

Possible issue with the regulator plug, or regulator circuits as PA suggested. Check voltages and be sure to use a test light on any circuits that supply any amps.

It appears that the connection for the yellow (sense) wire on the regulator plug where I spliced into the original harness came loose. I fixed it and am now getting full voltage at the plug. I'm guessing this was the issue but I won't know for sure until I get the alternator back. Would this loose/broken connection on the sense wire cause my charging issues?

EDIT: PA Performance just confirmed that if the alternator sense wire is not receiving voltage, the alternator will not charge.
88 Turbo Coupe: Front mount intercooler, MGW short throw shifter, full coilover conversion, tubular control arms front and rear, svo front brakes, vacuum assist brake swap, manual steering swap, GT35R turbo with external gate, pimpx ecu, 60lb injectors, 3 core aluminum radiator, corbeau fixed back seats, and the list goes on.
Reply

Jeff K Offline
Administrator
#4
Yes it would! Sounds like you got the problem fixed!
Jeff Korn

88 Turbo Coupe: Intake and exhaust mods, T3 turbo at 24 psi, forced air IC, water injection, BPV, Ranger cam, subframes, etc., etc.
86 Tbird 5.0 (original owner): intake, exhaust, valvetrain mods, 100 HP N2O, ignition, gears, suspension, etc., etc.
05 Taurus SEL Duratec daily driver
04 Taurus Duratec (wifes car)
02 Pontiac Grand Prix GT
95 Taurus GL Vulcan winter beater
67 Honda 450 Super Sport - completely customized
Reply





Users browsing this thread:
1 Guest(s)



Theme © iAndrew 2018 - Software MyBB