North American Turbocoupe Organization



High Idle Some Times
oldturboman Offline
Member
#1
My 88 TC Stock Automatic idles between 1800-2100 at times when at normal operating temp.Have cleaned IAB also installed one of those F2PZ-9F939-A Idle Air Adjust Spacers from Ford on it,idles fine sometimes fast others. Example- Drove to MD 75 miles idled fast 2100 drove home 75 miles idled 1000 both times in park,doesn't seem to do this cold just after warm-up.Doesn't matter if you run it hard or not.Any ideas anyone? By the way the idle plate discussed earlier in week by someone is still avilable from Ford kit cost me $16.69+ tax.You can still get copy of TSB 91-25-7 if you ask them for it. THX Oldturboman

------------------
1987&1988 Turbo T-Birds
1-1987 Auto 1-1987 5sp. Both Turbo T-Birds NATO Member
Reply

Jeff K Offline
Administrator
#2
Do you have your base idle speed and TPS voltage set properly? Check out the article in the tech section for info on how to set these.

------------------
Jeff Korn

88 Turbo Coupe: Intake and exhaust mods, T3 turbo at 20 psi, forced air intercooler, water injection, bypass valve, Ranger roller cam, subframes, etc., etc.. // 86 Tbird 5.0 (original owner): intake, exhaust, valvetrain mods, 100 HP nitrous, ignition, gears, suspension, etc., etc.... // 91 Escort: Bone stock winter car // 00 Windstar (wifes vehicle)
Jeff Korn

88 Turbo Coupe: Intake and exhaust mods, T3 turbo at 24 psi, forced air IC, water injection, BPV, Ranger cam, subframes, etc., etc.
86 Tbird 5.0 (original owner): intake, exhaust, valvetrain mods, 100 HP N2O, ignition, gears, suspension, etc., etc.
05 Taurus SEL Duratec daily driver
04 Taurus Duratec (wifes car)
02 Pontiac Grand Prix GT
95 Taurus GL Vulcan winter beater
67 Honda 450 Super Sport - completely customized
Reply

Kev Offline
Posting Freak
#3
If you don't have any vacuum leaks then I would say definately TPS. It is either bad or needs to be adjusted. Mine did the same thing and just needed to be adjusted.

Kev
Kev
1988 TC 5spd
Reply

BJL Offline
Moderator
#4
my car does that if i dotn warm it up in the mornign for more then 15mins, annoyign when its a 5spd, cuz you go to give it the same amount of ggas as you woud when its at 1000, and you end up spinnign the wheels.
i thinks it my tps, but my car is int eh shop now so i cant mess with it.

OLDTURBOMAN:
By The Way , hows the riveshaft doing?
get the BAS Sensors fixed??

------------------
Brian J Larkin
18 yr old male totally loves his tbird, Smile

1988 Turbo Coupe 5spd, dark blue

http://crazydriver358.5u.com
Brian J Larkin
88TC 328,000 miles
T3, FMIC ,3in stinger exhaust, PimpXS ECC,gillis,
255 walbro, afpr, 5spd swap,spec clutch, sn95 5 lug, Cobra 13in front brake. Vacuum assist brake conversion. 
89 Cougar XR7 3.8SC Auto
95 Ranger Splash 3.0 auto
Reply

oldturboman Offline
Member
#5
Thanks,Going to set TPS runs and idles to smooth to be vac leak.I should have thought of this but must have been in brain frezze mode.THX oldturboman

------------------
1987&1988 Turbo T-Birds
1-1987 Auto 1-1987 5sp. Both Turbo T-Birds NATO Member
Reply





Users browsing this thread:
1 Guest(s)



Theme © iAndrew 2018 - Software MyBB