North American Turbocoupe Organization



HELP
turbotronic Offline
Senior Member
#1
My car won't stay running. I installed a new starter (not because of the problem I have now, my old starter was showing signs of crap'ing out on me); the car has set for awhile due to having to change the clutch and replace u-joints. Because of this, I charged the battery. I can start it fine, it runs for about 2-3 sec.s and then dies. When it runs, the idle is fine. My car ran fine before I had to change the clutch and u-joints, no kind of problem like this. I need help. I can't think of what it might be, I'm still a newbie... [Image: frown.gif]

------------------
~Mark

88 TC (Black), 5 speed [K&N Cone, Gillis Valve (not installed yet), more coming soon]

88 TC (Parts Car)

[This message has been edited by turbotronic (edited 07-09-2005).]
~Mark

88 TC (Black), 5 speed
FMS 140MPH Speedo Big Grin
Oval Port Head
1.59/1.89 SS Valves
APC Cone (I know...Ricer part)
Gillis valve
TurboXS BOV-RFL
Alum. Water Pump
Walbro 190
3G

88 TC (Red) [Parts Car]
Reply

Pete D Offline
Administrator
#2
Pull the KOEO codes.

Check the fuel pressure: http://www.turbotbird.com/techinfo/Fuel_...ostics.htm
Pete Dunham


Reply

turbotronic Offline
Senior Member
#3
Ok...I pulled the codes and all I got was a code 23, twice. If you can't think of what code 23 is, it is "Closed throttle TPS voltage higher or lower than expected." WTF? What does this mean and what do I do?

------------------
~Mark

88 TC (Black), 5 speed [K&N Cone, Gillis Valve (not installed yet), more coming soon]

88 TC (Parts Car)
~Mark

88 TC (Black), 5 speed
FMS 140MPH Speedo Big Grin
Oval Port Head
1.59/1.89 SS Valves
APC Cone (I know...Ricer part)
Gillis valve
TurboXS BOV-RFL
Alum. Water Pump
Walbro 190
3G

88 TC (Red) [Parts Car]
Reply

Pete D Offline
Administrator
#4
First try reseting the TPS http://www.turbotbird.com/techinfo/Idle-...e2005.html

If it won't set to and hold a consistent idle valve, it's probably defective.
Pete Dunham


Reply

turbotronic Offline
Senior Member
#5
How do I go about doing that when my car won't stay running?

------------------
~Mark

88 TC (Black), 5 speed [K&N Cone, Gillis Valve (not installed yet), more coming soon]

88 TC (Parts Car)
~Mark

88 TC (Black), 5 speed
FMS 140MPH Speedo Big Grin
Oval Port Head
1.59/1.89 SS Valves
APC Cone (I know...Ricer part)
Gillis valve
TurboXS BOV-RFL
Alum. Water Pump
Walbro 190
3G

88 TC (Red) [Parts Car]
Reply

Pete D Offline
Administrator
#6
Just to get an initial tps reading.
skip the idle set.

Have you checked/cleaned the IAC? Meaning taken it off and cleaned it out w/ carb cleaner?
Pete Dunham


Reply

Hurff Offline
Senior Member
#7
I know the starter is no where near this... but...

It also sounds like if the hoses from the air meter box (having bad memory day, cant remember what its called...) to the turbo, or the intercooler hoses are off/loose/leaking...

(I learned this after rebuilding the top half, hitting the key, and getting it to run for no more than 10 sec, I hadnt put the remainer of the system together as I wanted to see if I had any leaks. Once all the hoses were there.. off it went...)
1987 TC - RIP
Reply

turbotronic Offline
Senior Member
#8
I have cleaned the IAC with carb cleaner and no luck. I'm unsure of the TPS tho. It may be faulty or something. I was unable to reset or whatever. I'm not really sure what I'm doing with it anyways...lol. Should I just replace it with a new one and see what that does?

Since I pulled the codes, would it have thrown a code for the fuel system?

Oh, I have put the air stuff all back together from the turbo to the cone filter. I know the car will run fine without the intercooler on cause I have done that before, I had faulty spark plug wires and I didn't want to have to take the IC off again.

------------------
~Mark

88 TC (Black), 5 speed [K&N Cone, Gillis Valve (not installed yet), more coming soon]

88 TC (Parts Car)

[This message has been edited by turbotronic (edited 07-10-2005).]
~Mark

88 TC (Black), 5 speed
FMS 140MPH Speedo Big Grin
Oval Port Head
1.59/1.89 SS Valves
APC Cone (I know...Ricer part)
Gillis valve
TurboXS BOV-RFL
Alum. Water Pump
Walbro 190
3G

88 TC (Red) [Parts Car]
Reply

Pete D Offline
Administrator
#9
are you saying the intercoole is off now, ans has been since you started this thread?
Pete Dunham


Reply

turbotronic Offline
Senior Member
#10
Yes and yes. It has been off for awhile since we had to replace my turbo with another from the parts car.

------------------
~Mark

88 TC (Black), 5 speed [K&N Cone, Gillis Valve (not installed yet), more coming soon]

88 TC (Parts Car)
~Mark

88 TC (Black), 5 speed
FMS 140MPH Speedo Big Grin
Oval Port Head
1.59/1.89 SS Valves
APC Cone (I know...Ricer part)
Gillis valve
TurboXS BOV-RFL
Alum. Water Pump
Walbro 190
3G

88 TC (Red) [Parts Car]
Reply





Users browsing this thread:
1 Guest(s)



Theme © iAndrew 2018 - Software MyBB