North American Turbocoupe Organization



Gauge Cluster
bigdogwazup Offline
Member
#1
I have a 87 T/C, and I've had on off and on problem with the fuel gauge every now an then not working or slow to come up, then today all the gauge's stopped working.
I could not find any topic on this in the tech articles, has any one had this problem before and what was the remedy?!?!
Stinger 3",Gillis Boosting 17psi, K&N,Forced4 bypass,RR looking for 300!!
Reply

87TurboBobby Offline
Senior Member
#2
Mine quit working once and it was the IVR (Instrument Voltage Regulator) It is on the back of the cluster and looks similar to a 9 volt battery to the best of my recollection. I bought one from Advance Auto Parts and it has worked fine for about 2 years now. I hope this helps.
90 Mustang GT Vert.
95 Mustang Vert
04 F150 Heritage
92 Chevy Silverado
Reply

bigdogwazup Offline
Member
#3
No else has any input on this..no one has ever had this problem or needed to fix this?!?!?
Stinger 3",Gillis Boosting 17psi, K&N,Forced4 bypass,RR looking for 300!!
Reply

BJL Offline
Moderator
#4
its proably a common problem, but the boards are gonna be slwoing dwon this week as carlisle all ford nats is comign up and evryone is gettign ready for it. so just wait a bit.

but i agree on testign the IVR to see if it putting out 5 volt with key on
Brian J Larkin
88TC 320k miles
T3, FMIC ,3in stinger exhaust, gillis,
255 walbro, afpr, 5spd swap,spec clutch, sn95 5 lug,.
89 Cougar XR7 3.8SC Auto
95 Ranger Splash 3.0 auto
Reply

Pete D Offline
Administrator
#5
"fuel gauge"
http://natomessageboard.com/ultimatebb.p...391#000000
http://natomessageboard.com/ultimatebb.p...390#000000
http://natomessageboard.com/ultimatebb.p...889#000000

More pages to be found
http://natomessageboard.com/ultimatebb.p...9;t=000165
Pete Dunham


Reply

bigdogwazup Offline
Member
#6
I'm not having a problem with just the fuel gauge...the speedo is working the tack is working,what's not working is oil water volt and fuel and is only now and then one time its working fine i'll get out of the car for 5min and then it stops?!?!?
Stinger 3",Gillis Boosting 17psi, K&N,Forced4 bypass,RR looking for 300!!
Reply

TCx2 Offline
Senior Member
#7
Quote:Originally posted by bigdogwazup:
I'm not having a problem with just the fuel gauge...the speedo is working the tack is working,what's not working is oil water volt and fuel and is only now and then one time its working fine i'll get out of the car for 5min and then it stops?!?!?
Instrument voltage regulator (IVR) would be my bet.
Kevin
TCx2
67 Green Ford Fairlane 428CJ 5spd
89 Fiji Blue Chrysler Conquest
03 Mercury Marauder "Supercharged"
03 Ford Excursion(King of the SUVs)
04 Mustang Cobra - Screaming Yellow
10 Challenger R/T "Supercharged"
Reply

teal95 Offline
Senior Member
#8
The IVR only feeds the water temp, oil pressure and fuel level. If all 3 are acting up, it's the IVR.

steve
'83 & '84 GT turbo EEC-Tuner
'85.5 & '86 SVO twEECer
2x '87 & '88 TC QuarterHorse
'93 LX 5.0 notch Moates chips
3x '95 & '96 GT
Reply





Users browsing this thread:
1 Guest(s)



Theme © iAndrew 2018 - Software MyBB