North American Turbocoupe Organization



gages not working
Donnell Offline
Junior Member
#1
Fuel volt and temp is not working need help and fog lights keep blowing fuses................
Donnell Louis
Reply

Pete D Offline
Administrator
#2
Volt gauges seldom work. Do the fuel and temp gauges work at all? Do they go up and down erratically? What does the oil gauge do?
Pete Dunham


Reply

HOODBIRD Offline
Senior Member
#3
Hey pete

I looked at his car the other day he has no volt, no temp, and no gas right nell? I was thinking its the ivr. The gages are not moving at all but he has tach, speed, and oil.


He has a nice bird in the workings.
86tc 5speed k&n, gfb boost controller, autometer gauges, tripminder, fmic, and upgrading as fast as possible
Reply

Jeff K Offline
Administrator
#4
If the oil gauge works, the problem is NOT the IVR, as the IVR feeds the oil, fuel and temp gauges. Is the wire connected to the temp sender? Fuel sender could be bad also. Might also want to check the connectors to the cluster to be sure they are clean and tight.
Jeff Korn

88 Turbo Coupe: Intake and exhaust mods, T3 turbo at 24 psi, forced air IC, water injection, BPV, Ranger cam, subframes, etc., etc.
86 Tbird 5.0 (original owner): intake, exhaust, valvetrain mods, 100 HP N2O, ignition, gears, suspension, etc., etc.
05 Taurus SEL Duratec daily driver
04 Taurus Duratec (wifes car)
02 Pontiac Grand Prix GT
95 Taurus GL Vulcan winter beater
67 Honda 450 Super Sport - completely customized
Reply

HOODBIRD Offline
Senior Member
#5
Thanks jeff and also the cluster wont light up.

His 88 makes me want to buy another bird
86tc 5speed k&n, gfb boost controller, autometer gauges, tripminder, fmic, and upgrading as fast as possible
Reply





Users browsing this thread:
1 Guest(s)



Theme © iAndrew 2018 - Software MyBB