North American Turbocoupe Organization



Fog lights
gadgetolds Offline
Posting Freak
#1
I keep blowing fuses after rewiring and im thinking I have wires wrong somehow, the drivers side came on fine, the passenger side dimmed and the fuse blew, any thoughts?
1988 Turbo Coupe - A237 cam, K&N Cone, T3(.60-.63), 255 Walbro, Gillis BV, gutted and knifed intakes, ported e6, 3" elbow/dp to dual 2.5s, Kirban and spearco fmic.

Up next, ported head, t3/t4 upgrade.
Reply

Steve B Offline
Member
#2
Did you add a relay in there? With mine i kept blowing fuses until i put the relay in the circuit.
Steve
1988 TC 5 Speed, Med Red, 60/48 T3, 24 PSI, Ranger Cam, Mallory 2 Step, 3" Dual Exhaust, FMIC w/ Forge BOV
Current Best 14.5 @ 93.64
My Car
More
Reply

gadgetolds Offline
Posting Freak
#3
No I didnt put in a relay, but was just reading about it.....
1988 Turbo Coupe - A237 cam, K&N Cone, T3(.60-.63), 255 Walbro, Gillis BV, gutted and knifed intakes, ported e6, 3" elbow/dp to dual 2.5s, Kirban and spearco fmic.

Up next, ported head, t3/t4 upgrade.
Reply

Jeff K Offline
Administrator
#4
Put in a relay, and check your wiring over.
Jeff Korn

88 Turbo Coupe: Intake and exhaust mods, T3 turbo at 24 psi, forced air IC, water injection, BPV, Ranger cam, subframes, etc., etc.
86 Tbird 5.0 (original owner): intake, exhaust, valvetrain mods, 100 HP N2O, ignition, gears, suspension, etc., etc.
05 Taurus SEL Duratec daily driver
04 Taurus Duratec (wifes car)
02 Pontiac Grand Prix GT
95 Taurus GL Vulcan winter beater
67 Honda 450 Super Sport - completely customized
Reply

trashline Offline
Posting Freak
#5
I was having the same problem, but I had corosion in my wires. I replaced the wires and it stopped blowing fuses. And covered the connections good
Brian

www.BCPCustom.com

06 Cobalt SS
66 mustang 289 C4 handfully modded

Stingers IC install and tbird photos
http://community.webshots.com/user/trashline
Reply





Users browsing this thread:
1 Guest(s)



Theme © iAndrew 2018 - Software MyBB