North American Turbocoupe Organization



Firm ride control problem
goldwing Offline
Senior Member
#1
My firm ride will not turn on 100%.
I bought the car last week and it was on perfectly all the time. I decided to turn it off just for the heck of it and now it only clicks on when cornering hard, then turns itself off again. I can hear a clicking sound as if the relay is turning on and off while cornering.
Any help in this matter is appreciated.
THANKS
T.C:87 5 speed
HOLSET(HE341/HY35W type-D),255 Walbro, No intercooler yet,8lbs boost,Timing @ 9,Low& C.C Plates & SN-95 Bumpsteer Kit, KYB-AGX Struts,Belt driven fan,Custom oil cooler feed,Relocated ECT,Relocated TFI,N/A Hood, showing 178K
Reply

T-BirdX3 Offline
Senior Member
#2
If you still have the ride switch in the auto position it is only suppose to come on at certain times (i.e. turning the steering wheel to a certain point left or right, hard acceleration, hard braking, and at like 80?mph)

The switches are a common problem, I believe there is a thread on here about taking it apart and cleaning it.
'88 T-Coupe 5 speed/'88 T-Coupe Auto
'87 T-Coupe 5 speed/'87 T-coupe 5 speed(76k orig mile)
..... and there was light!
http://i1224.photobucket.com/albums/ee36...tled-2.jpg
Reply

Jeff K Offline
Administrator
#3
By "click" I assume you mean it goes into FIRM mode and the green LED lights up? If so, it is working correctly. Should also do this at high throttle openings, high RPM, soeed over 84 mph, etc.
Jeff Korn

88 Turbo Coupe: Intake and exhaust mods, T3 turbo at 24 psi, forced air IC, water injection, BPV, Ranger cam, subframes, etc., etc.
86 Tbird 5.0 (original owner): intake, exhaust, valvetrain mods, 100 HP N2O, ignition, gears, suspension, etc., etc.
05 Taurus SEL Duratec daily driver
04 Taurus Duratec (wifes car)
02 Pontiac Grand Prix GT
95 Taurus GL Vulcan winter beater
67 Honda 450 Super Sport - completely customized
Reply

zbird Offline
Posting Freak
#4
I think it may be stuck in auto. My sons car does this on occasion. We will take the switch apart and clean it. That should fix it. If you always kept it in firm then the switch is probably corroded or dirty.
Dom Z
88 T/C med grey. 140 MPH Speedo, Kirban FPR, Gillis valve,Tripminder, K&N.
87 T/C Silver, Auto (project Daily driver)
99 F150 4x4
14 Ford Escape 2.0L Turbo
IF YOU DRIVE A FORD YOU DON'T NEED A GOODWRENCH!!
88 T/C http://www.youtube.com/watch?v=ZihO_D1FLCE
87 Silver http://www.youtube.com/watch?v=_dVU5axnb...ature=plcp
Reply

Jeff K Offline
Administrator
#5
^^^^^ +1

That switch is a piece of crap. OEM cost to Ford from their sypplier for the switch must have been 3 cents. At least the switch is fairly easy to take apart and get it working again.
Jeff Korn

88 Turbo Coupe: Intake and exhaust mods, T3 turbo at 24 psi, forced air IC, water injection, BPV, Ranger cam, subframes, etc., etc.
86 Tbird 5.0 (original owner): intake, exhaust, valvetrain mods, 100 HP N2O, ignition, gears, suspension, etc., etc.
05 Taurus SEL Duratec daily driver
04 Taurus Duratec (wifes car)
02 Pontiac Grand Prix GT
95 Taurus GL Vulcan winter beater
67 Honda 450 Super Sport - completely customized
Reply

zbird Offline
Posting Freak
#6
I leave mine in auto most of the time, but switch it to firm when I know I am gonna do some serious driving. Like later today when I get on Texas Motor Speedway to run a few laps.
Dom Z
88 T/C med grey. 140 MPH Speedo, Kirban FPR, Gillis valve,Tripminder, K&N.
87 T/C Silver, Auto (project Daily driver)
99 F150 4x4
14 Ford Escape 2.0L Turbo
IF YOU DRIVE A FORD YOU DON'T NEED A GOODWRENCH!!
88 T/C http://www.youtube.com/watch?v=ZihO_D1FLCE
87 Silver http://www.youtube.com/watch?v=_dVU5axnb...ature=plcp
Reply





Users browsing this thread:
1 Guest(s)



Theme © iAndrew 2018 - Software MyBB