North American Turbocoupe Organization



failed emissions...twice
TC23 Offline
Junior Member
#1
I had it smog tested once...and it failed miserably. Okay, so I replaced the 02 sensor, wires, cap, rotor, plugs, and gave it an oil change. I also timed it, and pulled codes, everything seemed perfect. Tested it again, HC's passed. But the CO's were still in leftfield. I asked the Jiffy Lube guy, what makes the HC's pass, and the CO's go sky-high? He blabbed out something that made no sense at all. Now what? Catalytic converter and muffler? Or should I just run some of that fuel additive that garuantees a passing test and hope for the best? Help...
TC23
Reply

Wags88TC Offline
Senior Member
#2
Does it smell rich? Burning oil? With close to 190K, I get nervous about the smog test. I always let the gas get real low, put in a couple a gallons of regular, a quart or so of alcohol(no, not Mr. Beam) and go test. Right after I fill the tank, to dilute the alky - it's reported to be bad on the rubber in the system.
It's not a cure-all, but it'll help a borderline engine.

------------------
Steve Wagner
Nato member
87TC auto(stock)
88TC, 5 speed, StageII Star clutch w/ StageIII pressure plate,lightened flywheel, K&N in fender, gillis valve, 255lph Walbro, Kirban adj.FPR,Bypass valve, 3" exhaust from turbo to tip (high flow cat/ Magnaflow muffler), A-pillar gauges(A/F & Boost), 16" ARE 5 spoke wheels(245/50VR16 Yokos'). Subframe connectors
Steve Wagner
Nato member
84 SVO
88TC, 5 speed, StageII Star clutch w/ StageIII pressure plate,lightened flywheel, K&N in fender, gillis valve, 255lph Walbro, Kirban adj.FPR,Bypass valve, 3" exhaust (high flow cat/ Magnaflow muffler), A-pillar gauges(A/F & Boost), 16" ARE 5 spoke wheels 7" front 8" rear(225/50VR16 / 245/50VR16 Yokos'). Subframe connectors
Reply





Users browsing this thread:
1 Guest(s)



Theme © iAndrew 2018 - Software MyBB