North American Turbocoupe Organization



Electrical Questions
Turbofan Offline
Member
#1
Ok...weird things. The car is running. It seems to be doing great. I have been driving around town and have put about 50 miles on the new engine. The tail lights and turn signals did not work. They did work, then next day they did not. No brake lights, not turn signals. The firm ride switch worked. The auto dimmer and auto lamp worked. Then the turn signals did not work. No brake lights. The firm ride light flickers in and out... almost blinking like the turn signal. The firm ride control did work, and I can not really tell that the car is going in and out of this... I think that it is just the light...Then the turn signals work again. The brake lights do not. I do have tail lights. The 3rd light in the window does not work. The light for low fuel works and the does not. The auto lamp works again. We looked at all of the fuses. Do you think that this is the master switch? Why would these things work and then not? Any ideas? Sorry I am not good at really describing this all.
I just want my Bird back!
Reply

tylerport Offline
Senior Member
#2
Sounds like you may have something wrong in the steering column. Ignition switches have been linked to this type of problem. They are not too expensive and fairly easily replaced.

------------------
Jim Portteus
NATO Member
86 Turbo Coupe, LA3 w/ Intercooler and Larger VAM, Gillis Valve, 2 1/2" Downpipe to 2" Duals w/ 18" Glasspacks, 245/50R16's, 140MPH Speedo and new paint.
Jim Portteus
Reply

Turbofan Offline
Member
#3
Someone else did tell me to jiggle the ignition. That did not seem to do anything. Strange that that one switch would do that. It is worth a shot. We have an extra.
I just want my Bird back!
Reply

Jeff K Offline
Administrator
#4
Multifunction switch?

------------------
Jeff Korn

88 Turbo Coupe: Intake and exhaust mods, T3 turbo at 20 psi, forced air intercooler, water injection, bypass valve, Ranger roller cam, subframes, etc., etc.. // 86 Tbird 5.0 (original owner): intake, exhaust, valvetrain mods, 100 HP nitrous, ignition, gears, suspension, etc., etc.... // 91 Escort: Bone stock winter car // 00 Windstar (wifes vehicle)
Jeff Korn

88 Turbo Coupe: Intake and exhaust mods, T3 turbo at 24 psi, forced air IC, water injection, BPV, Ranger cam, subframes, etc., etc.
86 Tbird 5.0 (original owner): intake, exhaust, valvetrain mods, 100 HP N2O, ignition, gears, suspension, etc., etc.
05 Taurus SEL Duratec daily driver
04 Taurus Duratec (wifes car)
02 Pontiac Grand Prix GT
95 Taurus GL Vulcan winter beater
67 Honda 450 Super Sport - completely customized
Reply

Turbofan Offline
Member
#5
We saved the steering column... I am hoping that will fix the problem. The "check engine" light comes on and off as well. I don't think that there is anything wrong with the engine. It just blinks on briefly and then off again, like the other lights that are malfunctioning.
I just want my Bird back!
Reply

Jeff K Offline
Administrator
#6
If the CEL is on for more than 1 or 2 seconds, there will be a code stored in the continuous memory part of the KOEO test. Run the KOEO test.

------------------
Jeff Korn

88 Turbo Coupe: Intake and exhaust mods, T3 turbo at 20 psi, forced air intercooler, water injection, bypass valve, Ranger roller cam, subframes, etc., etc.. // 86 Tbird 5.0 (original owner): intake, exhaust, valvetrain mods, 100 HP nitrous, ignition, gears, suspension, etc., etc.... // 91 Escort: Bone stock winter car // 00 Windstar (wifes vehicle)
Jeff Korn

88 Turbo Coupe: Intake and exhaust mods, T3 turbo at 24 psi, forced air IC, water injection, BPV, Ranger cam, subframes, etc., etc.
86 Tbird 5.0 (original owner): intake, exhaust, valvetrain mods, 100 HP N2O, ignition, gears, suspension, etc., etc.
05 Taurus SEL Duratec daily driver
04 Taurus Duratec (wifes car)
02 Pontiac Grand Prix GT
95 Taurus GL Vulcan winter beater
67 Honda 450 Super Sport - completely customized
Reply





Users browsing this thread:
1 Guest(s)



Theme © iAndrew 2018 - Software MyBB