North American Turbocoupe Organization



EGR Solenoid
hbusch Offline
Junior Member
#1
1988 Turbo Coupe, 5-Speed. Car started stalling when idling but ran fine. Check Engine Light would randomely come on for minute and go off. This wouldn't happen sometimes for days. Continued stalling at idle then started running bad. Same light simptoms. I took it to my mechanic. He replaced the O2 sensor and said "the EGR solenoid is bad and he can't get one. Your Check Engine Light will probably go on and off." I took it for a ride and it runs fine but the light is almost constantly on and it smells like rotten eggs. Also if I drive it for a long time, shut it off for a while, start it back up, it will not stay running. I have to keep my foot on the gas for about 5 minutes then it's fine.
EGR solenoid part #E5ZZ-9D474-A, NAPA Echlin #2-2323. Ford says it's been discontinued since 2000, NAPA discontinued 2/01. Thought about removing the EGR but how do I keep the Check Engine Light from coming on?
Reply

Walsted Offline
Posting Freak
#2
Welcome to the board.

If you have read a lot of the posts, you have probably guessed a lot of what is to follow, but just to make it official,...

Have you scanned the codes? Which ones come up? Does the vacuum connection to the fuel pressure regulator smell like fuel, by chance?

Due to the rotton eggs smell, I would guess that you are running rich, and from that, if I had to guess further, I would have guessed bad O2 sensor, as did your mechanic. But if you run the codes, you won't have to guess.

I ended up getting a replacement EGR solenoid from the junkyard. From what I understand, the EGR code will always come up if a certain recall was done. Others will have more info on that, and if your mechanic ran codes, that might be what he is basing that on.

Hope this helps.

------------------
Mike Walsted - NATO member
1986 5-speed TurboCoupe and 1985 5-speed XR7

[This message has been edited by Walsted (edited 11-08-2002).]
Mike Walsted - Sold my 1986 5-speed TurboCoupe
Reply

Jeff K Offline
Administrator
#3
If in fact the solenoid is bad, the solenoid isnt anything special. Any 12 Volt vac solenoid should work. I would try a TAD / TAB solenoid from a 5.0, which look nearly the same as the EGR solenoid.

With that said... Is the solenoid stuck open or stuck closed. If stuck open, EGR valve would be open all the time, and the car would idle like crap, or not at all. If stuck closed, You might experience some light throttle pinging, and slight gas mileage decrease, and increased NOx emissions (if you care), but other than that the car will run OK with the EGR valce always closed. Pull the vac line off the EGR valve and plug the line, and see if the car runs OK or not.

Pull the codes yourself and see what comes up. Like Mike said, I would bet you are running rich due to a bad 02, bad VAF, or bad FPR. Look for a continuous memory code 42 to confirm the rich running.

------------------
Jeff Korn

88 Turbo Coupe: Intake and exhaust mods, T3 turbo at 20 psi, forced air intercooler, water injection, bypass valve, Ranger roller cam, subframes, etc., etc.. // 86 Tbird 5.0 (original owner): intake, exhaust, valvetrain mods, 100 HP nitrous, ignition, gears, suspension, etc., etc.... // 91 Escort: Bone stock winter car // 00 Windstar (wifes vehicle)
Jeff Korn

88 Turbo Coupe: Intake and exhaust mods, T3 turbo at 24 psi, forced air IC, water injection, BPV, Ranger cam, subframes, etc., etc.
86 Tbird 5.0 (original owner): intake, exhaust, valvetrain mods, 100 HP N2O, ignition, gears, suspension, etc., etc.
05 Taurus SEL Duratec daily driver
04 Taurus Duratec (wifes car)
02 Pontiac Grand Prix GT
95 Taurus GL Vulcan winter beater
67 Honda 450 Super Sport - completely customized
Reply

hbusch Offline
Junior Member
#4
I haven't scanned the codes. As soon as I can I will do that and check the vacuum connection to the fuel pressure regulator.

By the looks of the tail pipes it is definitely running rich. The O2 sensor has been replaced.

I did have the recall done.

I believe the solenoid is stuck closed. No vacuum at the egr anytime no mater what throttle setting. If I hook 12V right to the solenoid it opens and the egr works. At idle it naturally runs like crap.

It was fairly warm here in New York today and when I started the car cold, it ran like crap. The egr was not open.
Thanks for your help Guys.



[This message has been edited by hbusch (edited 11-09-2002).]
Reply

hbusch Offline
Junior Member
#5
Quote:Originally posted by hbusch:
I haven't scanned the codes. As soon as I can I will do that and check the vacuum connection to the fuel pressure regulator.

By the looks of the tail pipes it is definitely running rich. The O2 sensor has been replaced.

I did have the recall done.

I believe the solenoid is stuck closed. No vacuum at the egr anytime no mater what throttle setting. If I hook 12V right to the solenoid it opens and the egr works. At idle it naturally runs like crap.

It was fairly warm here in New York today and when I started the car cold, it ran like crap. The egr was not open.
Thanks for your help Guys.

[This message has been edited by hbusch (edited 11-09-2002).]


Finally got it straightened out!

I don't use the car on the upstate NY roads during the winter (salt), so I didn't do anything with it. Since the season is fast approaching, I figured I'd better get working on it.

I found a brand new genuine FOMOCO EGR solenoid. Hooked it up. Ran worse. Actually ran good for about 15 seconds then went down hill. I noticed that when it started running bad, the fuel pump made a noise like it was straining.

Disconnected the battery to clear any codes. Hooked battery back up and started. Still ran bad and fuel pump making funny noise. Ran codes. Got a bunch. Checked everything and all checked OK.

The fuel pump noise got me thinking so I did what I should have done first. Check fuel pressure at rail. 80#! The fuel pressure regulator! Replaced that and runs great like it used to. The engine light was still coming on and off. After using the car for a while the light has stopped coming on.

Thanks to everyone for their help and suggestions.
Reply





Users browsing this thread:
1 Guest(s)



Theme © iAndrew 2018 - Software MyBB