North American Turbocoupe Organization



Cruise control switch
mario Offline
Junior Member
#1
hi , just took a ride and noticed my cruise control switch not workin(it was before)...meaning it will not "set" the speed but will accelerate........ any know issues i can look into ?
Really need my cruise controle Smile
Smile all stock ...Just added the G2 BoostValve(NICE)
Reply

Jeff K Offline
Administrator
#2
More details please.... do you mean you tap the set switch and it starts to accelerate instead of maintaining a constant speed? What happens if you press and hold the coast switch? What happens if you had a set speed, hit the brake to turn the CC off, and then tap the resume switch?

This sounds more like a problem with the CC servo or possibly the CC "amplifier" under the dash than a switch problem.
Jeff Korn

88 Turbo Coupe: Intake and exhaust mods, T3 turbo at 24 psi, forced air IC, water injection, BPV, Ranger cam, subframes, etc., etc.
86 Tbird 5.0 (original owner): intake, exhaust, valvetrain mods, 100 HP N2O, ignition, gears, suspension, etc., etc.
05 Taurus SEL Duratec daily driver
04 Taurus Duratec (wifes car)
02 Pontiac Grand Prix GT
95 Taurus GL Vulcan winter beater
67 Honda 450 Super Sport - completely customized
Reply

mario Offline
Junior Member
#3
hi,Jeff K it was workin fine, I tap the on and set switch, and it starts to accelerate instead of maintaining a constant speed....i then press "coast" to decelerate, can feel it turn off.

"what happens if you had a set speed, hit the brake to turn the CC off, and then tap the resume switch?" ....good question,it was working like this ..minus the resume switch..i would hit the brake...and recall it having to reset the cc....because the resume would keep accelerating...like it dose now when trying to set CC.
Smile all stock ...Just added the G2 BoostValve(NICE)
Reply

Scott Mabe Offline
Member
#4
Sounds like the same intermittent problem I have with mine. I rock the set/coast switch back and forth several times and most of the time will work normally.
1987 Turbo Coupe
1988 Thunderbird parts car/ possibly street/strip car
1990 F-250HD 460ci
2001 Pontiac Montana (wife's ride)

-PLEASE FORGIVE TYPOS, I USE SWYPE ON MY PHONE-
Reply

mario Offline
Junior Member
#5
thanks Scott i tried rockin the set/coast switch back and forth several times ...no luck for me.
ill try looking at the CC amplifier....have to find it.
really hard driving it for miles w a bad knee.

l just noticed my ignition lights(ch eng, and others not lighting up, could that be it ? looking for a blown fuse, did not find one, ill try again,and hope i find a blow fuse that is cousin this problem
Smile all stock ...Just added the G2 BoostValve(NICE)
Reply

Jeff K Offline
Administrator
#6
Possible ignition switching failing.
Jeff Korn

88 Turbo Coupe: Intake and exhaust mods, T3 turbo at 24 psi, forced air IC, water injection, BPV, Ranger cam, subframes, etc., etc.
86 Tbird 5.0 (original owner): intake, exhaust, valvetrain mods, 100 HP N2O, ignition, gears, suspension, etc., etc.
05 Taurus SEL Duratec daily driver
04 Taurus Duratec (wifes car)
02 Pontiac Grand Prix GT
95 Taurus GL Vulcan winter beater
67 Honda 450 Super Sport - completely customized
Reply





Users browsing this thread:
1 Guest(s)



Theme © iAndrew 2018 - Software MyBB