North American Turbocoupe Organization



Cruise control 87 TC
Scott Mabe Offline
Member
#1
The problem I'm having is if I try to use cruise control my TC tries to set a world land speed record! Soon you hit "SET" it starts accelerating until you turn cruise off. Any ideas?
1987 Turbo Coupe
1988 Thunderbird parts car/ possibly street/strip car
1990 F-250HD 460ci
2001 Pontiac Montana (wife's ride)

-PLEASE FORGIVE TYPOS, I USE SWYPE ON MY PHONE-
Reply

TurboBoost88 Offline
Member
#2
sounds like a sticking switch.
88 TurboCoupe,Midnight Metallic Blue on Blue cloth, 140 m.p.h. speedo, 96,000 miles, 5spd. Gills valve, many new parts waiting to be installed..88 TC, Silver, 5spd, My first car, wish I still had that one! Built for customers: 67 Ford Fairlane,69 Mach I,70 Mach I Clone,95 Ranger 2.3/5.0 EFI Conversion,99 Cobra Procharger SC-1 Install/Tune,Factory Five Racing Mark III Cobra #4114,1955 Black on Black Thunderbird for local Ford Dealer owner's wife.
Reply

Jeff K Offline
Administrator
#3
Or a stuck / bad vac apply valve in the CC servo. Unlikely to be the CC control unit (i.e., CC "amplifier"). They rarely fail.
Jeff Korn

88 Turbo Coupe: Intake and exhaust mods, T3 turbo at 24 psi, forced air IC, water injection, BPV, Ranger cam, subframes, etc., etc.
86 Tbird 5.0 (original owner): intake, exhaust, valvetrain mods, 100 HP N2O, ignition, gears, suspension, etc., etc.
05 Taurus SEL Duratec daily driver
04 Taurus Duratec (wifes car)
02 Pontiac Grand Prix GT
95 Taurus GL Vulcan winter beater
67 Honda 450 Super Sport - completely customized
Reply

Scott Mabe Offline
Member
#4
Like my signature says, the tc is new to me. The first couple times I tried cruise it worked fine. Then the other day before I had to work on the instrument cluster it started acting up. The car was supposed to have been parked for 6 or 7 years before I got it. So with that info, does that change anything?
1987 Turbo Coupe
1988 Thunderbird parts car/ possibly street/strip car
1990 F-250HD 460ci
2001 Pontiac Montana (wife's ride)

-PLEASE FORGIVE TYPOS, I USE SWYPE ON MY PHONE-
Reply

Jeff K Offline
Administrator
#5
The CC amplifier is up by the firewall on the driver side. Black plastic box about the size of a pack of cigs. About 6 or so wires going to it (I forget how many wires exactly). Any chance you kicked it, damaged the wiring to it when you had the cluster out?
Jeff Korn

88 Turbo Coupe: Intake and exhaust mods, T3 turbo at 24 psi, forced air IC, water injection, BPV, Ranger cam, subframes, etc., etc.
86 Tbird 5.0 (original owner): intake, exhaust, valvetrain mods, 100 HP N2O, ignition, gears, suspension, etc., etc.
05 Taurus SEL Duratec daily driver
04 Taurus Duratec (wifes car)
02 Pontiac Grand Prix GT
95 Taurus GL Vulcan winter beater
67 Honda 450 Super Sport - completely customized
Reply

Scott Mabe Offline
Member
#6
I don't believe so, since the problem showed up before I pulled the cluster.
1987 Turbo Coupe
1988 Thunderbird parts car/ possibly street/strip car
1990 F-250HD 460ci
2001 Pontiac Montana (wife's ride)

-PLEASE FORGIVE TYPOS, I USE SWYPE ON MY PHONE-
Reply

Scott Mabe Offline
Member
#7
Figured I'd update, as of right now the cruise is working the way it should. Didn't do anything, it just started working.
1987 Turbo Coupe
1988 Thunderbird parts car/ possibly street/strip car
1990 F-250HD 460ci
2001 Pontiac Montana (wife's ride)

-PLEASE FORGIVE TYPOS, I USE SWYPE ON MY PHONE-
Reply





Users browsing this thread:
1 Guest(s)



Theme © iAndrew 2018 - Software MyBB