North American Turbocoupe Organization



Cooling fans not coming on.
BabyBlueBird Offline
Member
#1
Long story short i got stuck in some traffic on my way home and my temp gauge started to creep up until I turned on my AC to kick the fan on. I was doing some diag on it tonight and when I turn the key on the passenger side main fan turns on but the drivers side aux fan does not. Also as the temp gauge starts to climb my fans will not come on at all, only when I turn on the ac. My first thought is the coolant temp sensor. I’ve had zero luck with any after market brands for them and I can’t source a ford part. Any ideas?

Edit: when I have time this weekend I plan to go through the basics like jumping the coolant temp connector and seeing if the coolant hose on the bottom of the intake is clogged.
Reply

88Slowbird Offline
Member
#2
Driver one only turns on when the temp gets to 220

Passenger side turns on at 210 or when A/C is on
1985 SVO: Pro 5.0 Shifter, Boport valve springs, Manual boost controller, AEM wideband
1985 TC 5 Speed
Reply

Mikey97D Offline
Senior Member
#3
Here's an article to test the fans:
https://turbotbird.com/thread-cooling-fan-test
1988 TC, 5 spd, Stinger 3" Exhaust, Schneider Roller Cam, -4° Cam Pulley, Cone Filter, Gilles Boost Control Valve set at 17 psi, Walbro 255 lph, CHE Rear Lower and Upper Control Arms, Braided Brake Lines, Hawk HPS 5.0 Front and HPS (F) Rear, CRES Inserts in front calipers, and '93 Cobra Wheels with General 235/50R17 Tires.   
Reply

BabyBlueBird Offline
Member
#4
Found my original temp sensor I took out a few years back and slapped it in. Works perfectly. Needle hits the half way point and the fan kicks on. Just amazes me a company can’t make a reliable replacement for such a simple sensor.
Jeff K and Mikey97D like this post
Reply

Kuch Offline
Senior Member
#5
I also use a Ford part for this temp sensor I get out of a 5.0 in the junkyard. Also, that passage tends to get clogged up real bad and the coolant doesn't floe over the sensor. Mine was real bad and had to use a drill to clean it out.
1988 Turbo Coupe, Black/Black, 5 Speed, Moonroof,  T3/T4, ported E6, 255LPH, Kirban, Stinger Exhaust, MGW shifter, K&N, Gillis valve, BP1.5, PIMPx, Koni's
1964 Ford Galaxie 500XL, 390 6V, Big Solid cam, Headers,3.89's, 4 Speed, Vast and fast
1960 Ford Starliner, 292 Y Block, 312 4bbl intake, headers, 3 Speed, slow and low
Reply





Users browsing this thread:
1 Guest(s)



Theme © iAndrew 2018 - Software MyBB