North American Turbocoupe Organization



Brake Lighjt
B D Offline
Member
#1
When I accelerate from a stop or slow speeds, my brake light comes on in first and second gear. Not my yellow ABS light, but my Red brake light. Is this light only to show that your parking brake is on? My brakes feel fine. Could the rear end be twisting and pulling on the parking brake cable? Anybody else have this happen?
B D

------------------
NATO Member
87 TC 5-Speed, Remote mount K&N filter system,Steeda Shifter
88 Thunderbird Sport 5.0
91 Ranger
87 Turbocoupe 5-Speed, Remote mount K&N filter system,Steeda Shifter,New Heater Core,new clutch.
88 Turbocoupe "Mach 1 SE "
88 Thunderbird Sport 5.0 (Retired)
91 Ranger
NATO Member
Reply

oldone Offline
Member
#2
It it is also turned on by the sensor in the Brake Master Reservoir, ck your brake fluid its probably low.

------------------
oldone
88 Maroon TC 5 speed
K&N Filter
Gillis boost valve
oldone
88 Maroon TC 5 speed
K&N Filter
Gillis boost valve
220,000 Miles
Reply

oldone Offline
Member
#3
My bad. I meant Master Cylinder reservoir.

------------------
oldone
88 Maroon TC 5 speed
K&N Filter
Gillis boost valve
oldone
88 Maroon TC 5 speed
K&N Filter
Gillis boost valve
220,000 Miles
Reply

Kev Offline
Posting Freak
#4
The light will also come on if your brake pads are badly worn. This allows the piston in the caliper to extent more making the fluid level drop a little (or something like that)
Kev
1988 TC 5spd
Reply

bigred Offline
Member
#5
bump

[This message has been edited by bigred (edited 11-22-2002).]
1988 TC T-5 swap,New Head,Wiseco .030 pistons ,5.5 Crower rods ,balanced ,24x12x3 intercooler,T-3 .60
Ranger Roller Cam,New brown tops.
New 3"cat and 3"single SS exhaust
Reply

bigred Offline
Member
#6
Try checking switch on parking brake mine was loose and kept comming on every time i hit a bump in the road

------------------
1988 TC T-5 swap,New Head,
Ranger Roller Cam,New brown tops.
3" cone filter(spectra)
,boost Set at 18 psi,No Knock sensor.
New 3"cat and 2.5 duals.
1967 F-100 Ranger short bed 352/2 barrel
1969 Pontiac LeMans
1988 E-350 Cargo van 351/C6
2000 Explorer 4.0 auto
1988 TC T-5 swap,New Head,Wiseco .030 pistons ,5.5 Crower rods ,balanced ,24x12x3 intercooler,T-3 .60
Ranger Roller Cam,New brown tops.
New 3"cat and 3"single SS exhaust
Reply

roushracing6 Offline
Junior Member
#7
Before I replaced my parking brake cables I had this occur when braking or hitting bumps. It was due to no tension on the parking brake pedal.

------------------
88 Tc 211,000 miles slowly rebuilding to stock. Silver with red leather interior loaded with all the toys. My second TC in 1988 bought one as my first new car purchase missed it ever since I sold it in 1991.
88 Tc 211,000 miles Silver with red leather interior loaded with all the toys. My second TC in 1988 bought one as my first new car purchase missed it ever since I sold it in 1991.T-bird died but not forgotten...
Reply

Jeff K Offline
Administrator
#8
I am beting on P brake switch also. To verify the problem, pull the connector off the park brake switch, and let it hang, and see if the problem goes away. If it does, the switch is the problem.

------------------
Jeff Korn

88 Turbo Coupe: Intake and exhaust mods, T3 turbo at 20 psi, forced air intercooler, water injection, bypass valve, Ranger roller cam, subframes, etc., etc.. // 86 Tbird 5.0 (original owner): intake, exhaust, valvetrain mods, 100 HP nitrous, ignition, gears, suspension, etc., etc.... // 91 Escort: Bone stock winter car // 00 Windstar (wifes vehicle)
Jeff Korn

88 Turbo Coupe: Intake and exhaust mods, T3 turbo at 24 psi, forced air IC, water injection, BPV, Ranger cam, subframes, etc., etc.
86 Tbird 5.0 (original owner): intake, exhaust, valvetrain mods, 100 HP N2O, ignition, gears, suspension, etc., etc.
05 Taurus SEL Duratec daily driver
04 Taurus Duratec (wifes car)
02 Pontiac Grand Prix GT
95 Taurus GL Vulcan winter beater
67 Honda 450 Super Sport - completely customized
Reply

Hybridbird Offline
Posting Freak
#9
Check your fluid level.Mine does the sma ehting when it is low.

------------------
Too much fun, what's that mean?That's like too much boost,there's no such thing.
"Finch....get the f*ck away from that Ficus......that's a jizz-free Ficus!"
Reply

B D Offline
Member
#10
It turned out to be the fluid level was low. The reservoir was discolored and I had not noticed that it was down. Thanks for the replys. I did not know that the light would come on if the fluid level was not right, so yall pointed me in the right direction.
Thanks
B D

------------------
NATO Member
87 TC 5-Speed, Remote mount K&N filter system,Steeda Shifter
88 Thunderbird Sport 5.0
91 Ranger
87 Turbocoupe 5-Speed, Remote mount K&N filter system,Steeda Shifter,New Heater Core,new clutch.
88 Turbocoupe "Mach 1 SE "
88 Thunderbird Sport 5.0 (Retired)
91 Ranger
NATO Member
Reply





Users browsing this thread:
1 Guest(s)



Theme © iAndrew 2018 - Software MyBB