North American Turbocoupe Organization



boost problem
84turbobird Offline
Member
#1
My brother just got an 88 turbo coupe and for some reason it pegs out the boost gauge. I checked all the lines running to the turbo and they are all the same as mine and I am getting 13-14 psi.
What would cause the boost to go up so high like that?
Reply

Jeff K Offline
Administrator
#2
Waste gate activator blown? Test: does it hold vac / pressure?

Wastegate stuck shut? Could be if the car sat for quite a while without running. Apply 10-15 psi air to WGA and see if WG arm moves to open WG.

Inaccurate boost gauge?

------------------
Jeff Korn

88 Turbo Coupe: Intake and exhaust mods, T3 turbo at 21 psi, forced air intercooler, water injection, bypass valve, Ranger roller cam, subframes, etc., etc.. // 86 Tbird 5.0 (original owner): intake, exhaust, valvetrain mods, 100 HP nitrous, ignition, gears, suspension, etc., etc.... // 91 Escort: Bone stock winter car // 02 Taurus Vulcan(wifes car)
Jeff Korn

88 Turbo Coupe: Intake and exhaust mods, T3 turbo at 24 psi, forced air IC, water injection, BPV, Ranger cam, subframes, etc., etc.
86 Tbird 5.0 (original owner): intake, exhaust, valvetrain mods, 100 HP N2O, ignition, gears, suspension, etc., etc.
05 Taurus SEL Duratec daily driver
04 Taurus Duratec (wifes car)
02 Pontiac Grand Prix GT
95 Taurus GL Vulcan winter beater
67 Honda 450 Super Sport - completely customized
Reply





Users browsing this thread:
1 Guest(s)



Theme © iAndrew 2018 - Software MyBB