North American Turbocoupe Organization



ALL SENSORS DEAD new eec, relay, and ignition swit
john shackleford Offline
Junior Member
#1
88' tc 5spd. Like the title says.. I have no power or vref signal to any sensors under the hood. Also no fuel pump prime. I was driving home one night and it just took a complete dump on me. I've replaced the ircm, eec, eec relay, ignition switch, and bypassed the inertia switch in the trunk.. on my last nerve here.. also I was able to jumper the fuel pump with the diag harness to verify relay operation. The issue is no power from the eec because I have no cel with key on. Please help
Reply

Jeff K Offline
Administrator
#2
Do you have 12 V at all 3 heavy gauge yellow wires going into the IRCM? Check with a test light at the IRCM connector with the connector removed from the IRCM. These 3 yellow wires are protected by fusible links, and all 3 need to be powered up for the car to run. The 3 yellow wires are not all connected in parallel inside the IRCM. Different wires feed power to different circuits in the IRCM. So even if the fuel pump runs vi grounding the EEC TEST connector pin does not mean othercircuits of the IRCM are being powered up.
Jeff Korn

88 Turbo Coupe: Intake and exhaust mods, T3 turbo at 24 psi, forced air IC, water injection, BPV, Ranger cam, subframes, etc., etc.
86 Tbird 5.0 (original owner): intake, exhaust, valvetrain mods, 100 HP N2O, ignition, gears, suspension, etc., etc.
05 Taurus SEL Duratec daily driver
04 Taurus Duratec (wifes car)
02 Pontiac Grand Prix GT
95 Taurus GL Vulcan winter beater
67 Honda 450 Super Sport - completely customized
Reply





Users browsing this thread:
1 Guest(s)



Theme © iAndrew 2018 - Software MyBB