North American Turbocoupe Organization



ABS not working
WyldeSoul Offline
Member
#1
My ABS isn't working at all. I'm not getting an ABS warning light, but it never comes on, so the bulb is likely out.

Power brakes work fine, but when I slam it down, the ABS does not kick in, at all.

Also, it seems that almost every time I push the petal, the brake pump initiates. From what I was told that shouldn't happen that often.

I checked on the brake diagnosis tech article, but it doesn't cover diagnosing the ABS.

What do I do to get ABS working again? Or rather, to find out what exactly is wrong?
The Wench 1987 Turbocoupe. 5 speed. Black with Raven/Charcoal interior. Beater.
Mods: Cone filter, manual 2 stage boost controller (Gillis style), Thrush Glasspack (Pre-axle dump.)
Reply

JohnL Offline
Senior Member
#2
So you're able to lock the tires up?
John Lewis
88 TC, 87 XR, 84 SVO
Currently deciding which is worth my time.
Reply

WyldeSoul Offline
Member
#3
Yup. Not a single pulse to the petal when I slam the brakes. I just skid.
The Wench 1987 Turbocoupe. 5 speed. Black with Raven/Charcoal interior. Beater.
Mods: Cone filter, manual 2 stage boost controller (Gillis style), Thrush Glasspack (Pre-axle dump.)
Reply

JohnL Offline
Senior Member
#4
You've got to check the light first and get it working if it's out, then there is a procedure somewhere for checking ABS codes, it has a self-diagnostic just like the EEC.
John Lewis
88 TC, 87 XR, 84 SVO
Currently deciding which is worth my time.
Reply

WyldeSoul Offline
Member
#5
Righto. Is it at all difficult to get the light?

Rather, is it sold just as a bulb (Is it just a generic bulb?) or do I have to go to a junkyard?
The Wench 1987 Turbocoupe. 5 speed. Black with Raven/Charcoal interior. Beater.
Mods: Cone filter, manual 2 stage boost controller (Gillis style), Thrush Glasspack (Pre-axle dump.)
Reply

JohnL Offline
Senior Member
#6
I think it's just a plain 194 bulb. I took mine out and left it out Smile . I don't remember how I got to it, but it wasn't terribly difficult, I think maybe you have to pull the dash trim plate?
John Lewis
88 TC, 87 XR, 84 SVO
Currently deciding which is worth my time.
Reply

Wjameson Offline
Member
#7
The ABS bulb is mounted in the speedo cluster, probably take 30 to 45 mins to to take it out, I would recommend starting by removing plastic panels below steering wheel (screws for trim panel are behind it) them work your way up, once you have removed trim pieces (if I remeber correctly) the are 5 or 6 screws that hold the cluster in once those screws are removed you can start pulling the cluster out WARNING the vacum line for boost gauge and harness connector are sometimes jammed up in the dash, you should be able to get it out enough to remove them from the back of the cluster ooops almost forgot lock you tilt wheel down makes it easier when removing cluster

Bill
87 TC 5spd, 2006 Daytona R/T Charger,03 Anniversary HD Lowrider
Reply

Jeff K Offline
Administrator
#8
If ou hit the brakes REALLY hard, the pump will run after every 1 or 2 brake applications. More gentle braking will result in the pump running every 2 to 6 brake applications.

As others have said, replace the BAS bulb, and run codes. Most common cause of ABS light on / no ABS operation is an open cable to one of the wheel sensors.
Jeff Korn

88 Turbo Coupe: Intake and exhaust mods, T3 turbo at 24 psi, forced air IC, water injection, BPV, Ranger cam, subframes, etc., etc.
86 Tbird 5.0 (original owner): intake, exhaust, valvetrain mods, 100 HP N2O, ignition, gears, suspension, etc., etc.
05 Taurus SEL Duratec daily driver
04 Taurus Duratec (wifes car)
02 Pontiac Grand Prix GT
95 Taurus GL Vulcan winter beater
67 Honda 450 Super Sport - completely customized
Reply





Users browsing this thread:
1 Guest(s)



Theme © iAndrew 2018 - Software MyBB