North American Turbocoupe Organization

Full Version: China Turbo Popped
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Here's a few pic's of my China ebay T3T4 after it died. Was only at 15 pounds when I heard a big pop sound then a massive smoke screen at 70 mph until it burned 4 quarts of oil before I came to a stop. I think the nut on the compressor caused it, cause I could loosen it with my finger ?

[Image: P1060198_zpsk84kajtt.jpg]
[Image: P1060197_zpssxv6jupb.jpg]
[Image: P1060194_zpsmezyzfk0.jpg]
That looks NASTY! Sorry to hear about your issues, but I guess you get what you pay for. My American made Garrett T3 has operated perfectly at up to 24 psi boost for over 100K miles with zero issues of any kind.
buy 1 from Chip () , he replaces all of the internals with much better stuff...

https://bigrmotorsports.com
Always wanted to see what the guts look like and now I know HA !

I got a IHI, T3, Garrett 50 and 2 of these Chinese ones.

I notice on the china one the thrust bearing sets on pins and is not bolted down either but the bearing looked really good.

Going to check my other one and see how tight the compressor nut is?

Going to get another Garrett but with a .48 AR to spool a little faster.
(08-04-2019, 06:46 PM)Jeff K Wrote: [ -> ]That looks NASTY! Sorry to hear about your issues, but I guess you get what you pay for. My American made Garrett T3 has operated perfectly at up to 24 psi boost for over 100K miles with zero issues of any kind.

I was laughing so hard cause of all the smoke and I bet the Control Tower at Dyess AFB thought there was an invasion coming from the West !
When I first got my TC back in 2000 it had the stock IHI that wasnt in great shape to start with. After doing this and that under the hood I went for a ride, and got on it an a lightly traveled country road (i.e., no cops). Foot to the floor, 5K+ RPM I took a quick glance at my newly installed A pillar mounted boost gauge. It was pinned at 30 psi. I heard a BANG, engine lost power and the smoke show out the exhaust was VERY impressive. There was no wind that day so the smoke just hung over the roads on my way home. Anyone could have followed me home just following the smoke trail (that is if they could see the road, which was unlikely. .

Turns out I forgot to put the hose on the WGA, so no boost control at all. But it did give me a good excuse to upgrade to a T3!!
I now call my car a ThunderJet LOL

I saw on YouTube a guy made a gas turbine out of a turbo ? Might just have to try that.
(08-04-2019, 05:34 PM)BigJake Wrote: [ -> ]I think the nut on the compressor caused it, cause I could loosen it with my finger ?

[Image: P1060198_zpsk84kajtt.jpg]

You already answered your own question as to what caused it, it was a 5 letter word....

China.

I’m not anti-China; I realize that it’s a global economy. I have a room full of vintage Apple computers, Macs and PCs—guess where THEY were pretty much all made?

Turbochargers are a different story.

China-made products are price-competitive because they generally use a lower quality of steel and other parts; I would also be skeptical of the product’s engineering phase in light of that. Components of the highest quality aren’t required to manufacture an electronic device; turbos can spin as high as 120,000 rpms, so great precision and durable/long-lasting parts are essential for any kind of reliability.